summaryrefslogtreecommitdiff
path: root/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/rrdtool/rrdtool-1.8.0.ebuild')
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.8.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild b/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild
index ad96cbb55058..9d56454bf1fe 100644
--- a/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild
@@ -159,13 +159,13 @@ lua_src_compile() {
# We do need the CMOD-dir path here, otherwise libtool complains.
# Use the real one (i.e. not within ${ED}) just in case.
local myemakeargs=(
- LUA_CFLAGS=$(lua_get_CFLAGS)
+ LUA_CFLAGS="$(lua_get_CFLAGS)"
LUA_INSTALL_CMOD="$(lua_get_cmod_dir)"
)
emake "${myemakeargs[@]}"
- popd
+ popd || die
}
python_compile() {