summaryrefslogtreecommitdiff
path: root/net-analyzer/raddump
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/raddump')
-rw-r--r--net-analyzer/raddump/Manifest2
-rw-r--r--net-analyzer/raddump/files/raddump-0.3.1-gcc14.patch13
-rw-r--r--net-analyzer/raddump/raddump-0.3.1-r1.ebuild24
3 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/raddump/Manifest b/net-analyzer/raddump/Manifest
index a45c6a8b5bd6..41e588e7a0a8 100644
--- a/net-analyzer/raddump/Manifest
+++ b/net-analyzer/raddump/Manifest
@@ -1,3 +1,5 @@
+AUX raddump-0.3.1-gcc14.patch 585 BLAKE2B d8c2531175bcb409c356d4dd3551d3581852fca2c79410d292c7460f09f5babe21ef57059e7a236fda340b465ac21d015228ec9185aec9e0707cdc93984c22dd SHA512 838a1b155668023e02fed4df0bfc91ed645e1282f9736a9958ba46ce3e08e8b74f0549fd1d6dc78ad75340e6f5b9b0c75b2c48cdc37d66607f0daa4b8d147231
DIST raddump-0.3.1.tar.gz 175078 BLAKE2B b65bbf2200792c41ffe8363aaedc3e009fddc0b684f647352bba5011e84ab99c4741f9cf567e6a668c08ba7e4f8df144875379fbc7f1fff1a2217cdfbde1fde8 SHA512 35daf9c31fc21f29e713fa0f3e5c438f5762087060068506f6e0d829a0fabe74a99fdd1a35bf878aa0cbf5a5f0bec212b0af51b7c3df4e58ec0165b4dee023fa
+EBUILD raddump-0.3.1-r1.ebuild 488 BLAKE2B 547c7d4f772ef5e97089fa935c68d66088becb1af7a034adc154393eb0ec1b83bc4e09d1767a39101fb46bcb8bb084fe3bc4570de6e0dadfb8933f240b5b8026 SHA512 62230641886fa4d0683cf7a28bdada8768a170978198b7e4db13f21071030836b00952c56f10ea7350bdfaa72ce822ff3e8ea71b2450e3d0e6782a99c70787db
EBUILD raddump-0.3.1.ebuild 450 BLAKE2B 3a1be6e49b68d1b2d9637757db934f6a8bdd7f0eefe48ab751202d5fefe03f3befa617f0878789fa66709813ba218dfda6b358608226a56044f50011ed5db6f6 SHA512 0b3ddbd92905c3964e164f967619a5343c2f5d870d4907c7fcb3f308f4a85e1ef2d1d9837e6ad191d9c60df92e9280ffc3b70fa7444cbd1150fefe29421b4350
MISC metadata.xml 304 BLAKE2B ab2f1e83c8ea21e1f04ec7be3fd04f3dc728711404958ce05d2fffe6c17a5ac76fe4a79c33813fbc18d368d110b08f93c16f8504881f264d473f05abcd4177c4 SHA512 de837f297d4389532fd32cea3e9a81cb80abee01fb1715d6d75b6585d3fa372f9f2852243a5a8d8a024cc313ffce1c912622adc0ca43e3d3dcaeebf5fbc71c57
diff --git a/net-analyzer/raddump/files/raddump-0.3.1-gcc14.patch b/net-analyzer/raddump/files/raddump-0.3.1-gcc14.patch
new file mode 100644
index 000000000000..82fecf6cb1da
--- /dev/null
+++ b/net-analyzer/raddump/files/raddump-0.3.1-gcc14.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/919358
+diff -ru a/pktrecord.h b/pktrecord.h
+--- a/pktrecord.h 2025-01-05 15:55:08.349684611 +0400
++++ b/pktrecord.h 2025-01-05 15:57:49.645807285 +0400
+@@ -25,7 +25,7 @@
+ unsigned int included_len; /* how much of it we actually have here */
+ unsigned int ts_secs; /* timestamp, seconds component */
+ unsigned int ts_usecs; /* timestamp, microseconds component */
+- unsigned char *pkt_data; /* pointer to the actual packet data */
++ const unsigned char *pkt_data; /* pointer to the actual packet data */
+ };
+
+ struct prec_handle;
diff --git a/net-analyzer/raddump/raddump-0.3.1-r1.ebuild b/net-analyzer/raddump/raddump-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..85f7315b3a27
--- /dev/null
+++ b/net-analyzer/raddump/raddump-0.3.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="RADIUS packet interpreter"
+HOMEPAGE="https://sourceforge.net/projects/raddump/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=net-analyzer/tcpdump-3.8.3-r1"
+DEPEND=${RDEPEND}
+
+PATCHES=( "${FILESDIR}/${P}-gcc14.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}