summaryrefslogtreecommitdiff
path: root/net-analyzer/ospd
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ospd')
-rw-r--r--net-analyzer/ospd/Manifest6
-rw-r--r--net-analyzer/ospd/metadata.xml10
-rw-r--r--net-analyzer/ospd/ospd-1.3.2.ebuild9
-rw-r--r--net-analyzer/ospd/ospd-2.0.0.ebuild32
4 files changed, 50 insertions, 7 deletions
diff --git a/net-analyzer/ospd/Manifest b/net-analyzer/ospd/Manifest
index ecb61469a5f0..16b01a37b29f 100644
--- a/net-analyzer/ospd/Manifest
+++ b/net-analyzer/ospd/Manifest
@@ -1,3 +1,5 @@
DIST ospd-1.3.2.tar.gz 39097 BLAKE2B 4c102e1e6857f89015666950e2d7a107bf81c861f9c6d4d74aab33f77585ea871e353aa95deb3f84a1bb4cd391f40121ca927835ebec9db2545eb8f606e96df7 SHA512 26ec0b45d74df687264ce2d5e42a6f51cfb982f8fe00863294b990ee8db819b7f54ebf3f095094c32c2bc91a51d987ac83f15f4bf15e931d4ffd215b72ac6bec
-EBUILD ospd-1.3.2.ebuild 738 BLAKE2B 59907c080ef008560f9f56157f341f2a56684d384015bfda76bf7fb38668f26f1c74b9bd2c5e32631240afdc2571d72df02f1236a084791736e78c9f7202ca92 SHA512 4ace8420652b2017aa0425e35a562c0a5e211ab2967c3af72dbbb7804aa2d3ebe6d2274c3ef48ab1158dbaf8805e7f98d5ae52d6cbce1eaa4c51a3482aa774e0
-MISC metadata.xml 435 BLAKE2B 4d40c4dcffe9bfd81d1c1b517b4e6d6e1e658f9d6be65f8ad962ecbbee78bf0cc6bbb5805f2e056375c7371697a453453f8eeae40bae1bdf890be8f3e23ccfbc SHA512 fc802728917b8ebc3c43e3c35ce1fa7b8aa30d89d60abcfcd82eb6baf0152d02384b2e336664942bd89c3ed27a418f37a13699b68a424f36645c51c1310a6e16
+DIST ospd-2.0.0.tar.gz 81645 BLAKE2B 4c0c7af3caf274ea9e6a43790eb1e9d386ce42d9976e5e9625b49ffe12d8db2e613109458dcc59f322bc00aee39a4a89045caf302182474d1fab4ca1c4ff1bcf SHA512 971b4b57c39844ef08a0ae56d4bf87f0440c993960b5ad37516c622ad41eb2ab30fabb9d0a05fd043a9a1d98e446eaab9d5018cc1607fd711c533475f4703012
+EBUILD ospd-1.3.2.ebuild 721 BLAKE2B 6c3700ac9a17745447f82f5468d7f077b8d5c98b658870ec58fd36ca0afc788446bde9a1374f2442fe465ca5dc829d16ca0681e67abfd155a04f288534a99c50 SHA512 29e7f73153030fe522041d1728872076e91507da86d6a468df00eee07dcf20c476650eb787780251891304f92f7cd5352980b85b7450bb3028531a7db3c9a9b0
+EBUILD ospd-2.0.0.ebuild 720 BLAKE2B ded312a73884a2a16ab8f94a98ae17a7b49a240f8c5cdc82baf6f6aa3980c3574888f728cc5cacb8748ac2cd7ae7d6325bb8aa65243eb697a2ab21471b329f88 SHA512 d82bc6fc8f91d3be650b0a1d1337e7967155e87bac293b748936bf8a8e16f64d5b37c9823a5eaa84604eb148142cffbf8261c96ae6af5712b6e59a2227cc32f4
+MISC metadata.xml 879 BLAKE2B 312903697fda388ac1a9b8c773f69836154e9ea62ee28c1b8248c3e751a6df14dd0f25e1f5d05cca297309aadc0785139ea35c87eab0f5d0f3639a17cb19b570 SHA512 4c276360cc13793e6f505ac0e0b767fa8af277a696a9e64aa37a671780d1b7fa82812d25c2be25dd4542201ab5083d2721746344f46fe548999d4b615c2ceadc
diff --git a/net-analyzer/ospd/metadata.xml b/net-analyzer/ospd/metadata.xml
index fa26aa942e17..c20e7ad3a230 100644
--- a/net-analyzer/ospd/metadata.xml
+++ b/net-analyzer/ospd/metadata.xml
@@ -12,4 +12,14 @@
<use>
<flag name="extras">Html docs support</flag>
</use>
+ <longdescription lang="en">
+ OSPD is a base class for scanner wrappers which share the same communication protocol:
+ OSP (Open Scanner Protocol). OSP creates a unified interface for different security scanners
+ and makes their control flow and scan results consistently available under the central
+ Greenbone Vulnerability Manager service.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">greenbone/ospd</remote-id>
+ </upstream>
</pkgmetadata>
+
diff --git a/net-analyzer/ospd/ospd-1.3.2.ebuild b/net-analyzer/ospd/ospd-1.3.2.ebuild
index 9b9c31af66ea..ce11b4a1aa1d 100644
--- a/net-analyzer/ospd/ospd-1.3.2.ebuild
+++ b/net-analyzer/ospd/ospd-1.3.2.ebuild
@@ -6,20 +6,19 @@ EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1
-DESCRIPTION="Openvas OSP (Open Scanner Protocol)"
-HOMEPAGE="http://www.openvas.org/"
+DESCRIPTION="Base class for scanner wrappers,communication protocol for GVM"
+HOMEPAGE="https://www.greenbone.net/en/"
SRC_URI="https://github.com/greenbone/ospd/archive/v1.3.2.tar.gz -> ${P}.tar.gz"
SLOT="0"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
KEYWORDS="~amd64 ~x86"
IUSE="extras"
RDEPEND="
dev-python/defusedxml[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]
- >=net-analyzer/greenbone-security-assistant-7.0.3"
+ dev-python/paramiko[${PYTHON_USEDEP}]"
DEPEND="
${RDEPEND}"
diff --git a/net-analyzer/ospd/ospd-2.0.0.ebuild b/net-analyzer/ospd/ospd-2.0.0.ebuild
new file mode 100644
index 000000000000..ae035362d7db
--- /dev/null
+++ b/net-analyzer/ospd/ospd-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Base class for scanner wrappers,communication protocol for GVM"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/ospd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+python_compile() {
+ if use extras; then
+ bash "${S}"/doc/generate || die
+ HTML_DOCS=( "${S}"/doc/. )
+ fi
+ distutils-r1_python_compile
+}