summaryrefslogtreecommitdiff
path: root/net-analyzer/ospd/ospd-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ospd/ospd-1.3.2.ebuild')
-rw-r--r--net-analyzer/ospd/ospd-1.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/ospd/ospd-1.3.2.ebuild b/net-analyzer/ospd/ospd-1.3.2.ebuild
new file mode 100644
index 000000000000..976983ae9504
--- /dev/null
+++ b/net-analyzer/ospd/ospd-1.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Openvas OSP (Open Scanner Protocol)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="https://github.com/greenbone/ospd/archive/v1.3.2.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=net-analyzer/greenbone-security-assistant-7.0.3"
+
+DEPEND="
+ ${RDEPEND}"
+
+python_compile() {
+ if use extras; then
+ bash "${S}"/doc/generate || die
+ HTML_DOCS=( "${S}"/doc/. )
+ fi
+ distutils-r1_python_compile
+}