summaryrefslogtreecommitdiff
path: root/net-analyzer/nrpe
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nrpe')
-rw-r--r--net-analyzer/nrpe/Manifest2
-rw-r--r--net-analyzer/nrpe/nrpe-3.2.1-r3.ebuild (renamed from net-analyzer/nrpe/nrpe-3.2.1-r2.ebuild)22
2 files changed, 14 insertions, 10 deletions
diff --git a/net-analyzer/nrpe/Manifest b/net-analyzer/nrpe/Manifest
index 9c0f35c6aa3d..2ee465d781da 100644
--- a/net-analyzer/nrpe/Manifest
+++ b/net-analyzer/nrpe/Manifest
@@ -4,5 +4,5 @@ AUX nrpe.service 242 BLAKE2B 715f0e8b91d6c40405d6d1f3689bbbf750e61e78e1d727debbe
AUX nrpe.xinetd.2 245 BLAKE2B 3e9db31c7d5b28dab18d2f5855d0465f25fc9cf4a70deac9a5d0c87c7cc546a33b432dbca172a49addadc0bd6583d870ec0fe350bf60e015e325d8bb923aca47 SHA512 d687cb2a5babfd28a97d3a5f1ac665758341ecc37fdd0193dbf0df4cba68c88aa24776a33a706989843fa5356b2e3e995662a823ceb2b86ba8f846f8c47e18fb
DIST nrpe-3.2.1.tar.gz 518015 BLAKE2B c9be2bf24e3d9977a7ff5c2f0e08bfe841729289af836bb7ac6ccb2c173a519958b12cc3e90ece612ac6c2527ad472ef1464be648a66b11ff8ad483d5ad78cc1 SHA512 ec6ff42a00bd97ed80010a82e26dc35fd419f2feda65820cda0108068173c1ae44eee698833a50fd2079429a6f5eb1321c4f06b09c6708bc5fbe48f176389856
EBUILD nrpe-3.2.1-r1.ebuild 2516 BLAKE2B c9221e5f220d7231f9c293a0fbbd5aca68600806538f8dc7bba18c03d1f9d72ab3298ef3098483475212a5f10c2c520ed7fd1914d868b5de2016001b7baf03b5 SHA512 669ba9444ddb021969ec9987fa27bd32bb059410acfdcc344e505cfd562088123fcf227d8bd0d17987670332924fe2dbfd11beaeae146aa49f3cc4a3b8f63348
-EBUILD nrpe-3.2.1-r2.ebuild 2506 BLAKE2B 464ec7948b8771c80b12de47abacd8f4f3326d21e660cd6851e0e7de2ef56b0a4deccf2a34af6ca7c10b06032ad5e0c29f9d2394a269f5732324faf7bbc80310 SHA512 97ed66451767208e94398f6cf7ca86c6e6d2ccf05660d60349e9e8f2713fd28aae6df9f05a8884636baf150b7d6e8985db6547e581c772074f3f4a972319c107
+EBUILD nrpe-3.2.1-r3.ebuild 2822 BLAKE2B 6d2b46889d9da9a40d2d67b21c62aa714b1bcc5dcb504bd5079c87f95dbd5967178ba025d84d9e577c4c8053e4cf3831f8e28814f093b6c51b9dcb5cd2ff5482 SHA512 5097efacb350bea0b2f181a43d950481ce1c1703d488dd27fbd35efe9d15d0fd28e2213f8b77ff1adbfc6d0dff19f57247c98c4cb021342e55f0669802799d51
MISC metadata.xml 770 BLAKE2B 93991f7ee4c1b6c26b67e873fae0cdb66170cd93ba6b79d6e798cb2605126888a996f633eccd038ece2a822d1b92498c2036746bb3a1add2e336c6026c2db86d SHA512 48693abab21581eff977b8deaa5fabc5d388960c9cd090b590a1f6d3c8d37b63fe33ec86d6f95d7435404314b84053f8c2ca84b0f33c6c7241ea7260f82a3a27
diff --git a/net-analyzer/nrpe/nrpe-3.2.1-r2.ebuild b/net-analyzer/nrpe/nrpe-3.2.1-r3.ebuild
index 7838b676b308..0dad49acfdf5 100644
--- a/net-analyzer/nrpe/nrpe-3.2.1-r2.ebuild
+++ b/net-analyzer/nrpe/nrpe-3.2.1-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit systemd user
+EAPI=7
+inherit systemd
DESCRIPTION="Nagios Remote Plugin Executor"
HOMEPAGE="https://github.com/NagiosEnterprises/nrpe"
@@ -13,7 +13,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="command-args libressl selinux ssl"
-DEPEND="sys-apps/tcp-wrappers
+DEPEND="acct-group/nagios
+ acct-user/nagios
+ sys-apps/tcp-wrappers
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
@@ -24,11 +26,6 @@ RDEPEND="${DEPEND}
PATCHES=( "${FILESDIR}/nrpe-3.2.1-eliminate-systemd-pid.patch" )
-pkg_setup() {
- enewgroup nagios
- enewuser nagios -1 -1 -1 nagios
-}
-
src_configure() {
# The configure script tries to detect what OS, distribution, and
# init system you're running and changes the build/install process
@@ -36,6 +33,13 @@ src_configure() {
# because we don't want it guessing, for example, whether or not
# to install the tmpfiles.d entry based on whether or not systemd
# is currently running (OpenRC uses them too).
+ #
+ # Note: upstream defaults to using "nagios" as the default NRPE
+ # user and group. I have a feeling that this isn't quite correct
+ # on a system where "nagios" is also the user running the nagios
+ # server daemon. In the future, it would be nice if someone who
+ # actually uses NRPE could test with an unprivileged "nrpe" as
+ # the user and group.
econf \
--libexecdir=/usr/$(get_libdir)/nagios/plugins \
--localstatedir=/var/lib/nagios \