summaryrefslogtreecommitdiff
path: root/net-analyzer/nmap/nmap-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-9999.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 62661ccfa927..9470b5ddbf08 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
LUA_COMPAT=( lua5-3 )
LUA_REQ_USE="deprecated"
@@ -14,8 +14,6 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/nmap/nmap"
- # Just in case for now as future seems undecided.
- LICENSE="NPSL"
else
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/nmap.asc
inherit verify-sig
@@ -24,10 +22,9 @@ else
SRC_URI+=" verify-sig? ( https://nmap.org/dist/sigs/${P}.tar.bz2.asc )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
- LICENSE="|| ( NPSL GPL-2 )"
fi
+LICENSE="|| ( NPSL GPL-2 )"
SLOT="0"
IUSE="ipv6 libssh2 ncat nping +nse ssl symlink +system-lua"
REQUIRED_USE="
@@ -54,9 +51,10 @@ RDEPEND="
system-lua? ( ${LUA_DEPS} )
"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
if [[ ${PV} != *9999* ]] ; then
- BDEPEND+="verify-sig? ( sec-keys/openpgp-keys-nmap )"
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-nmap )"
fi
PATCHES=(
@@ -92,7 +90,7 @@ src_prepare() {
eautoreconf
if [[ ${CHOST} == *-darwin* ]] ; then
- # we need the original for a Darwin-specific fix, bug #604432
+ # We need the original for a Darwin-specific fix, bug #604432
mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
fi
}
@@ -112,16 +110,14 @@ src_configure() {
--cache-file="${S}"/config.cache \
--with-libdnet=included \
--with-pcre="${ESYSROOT}"/usr \
+ --without-dpdk \
--without-ndiff \
--without-zenmap
}
src_compile() {
local directory
- for directory in . libnetutil nsock/src \
- $(usex ncat ncat '') \
- $(usex nping nping '')
- do
+ for directory in . libnetutil nsock/src $(usev ncat) $(usev nping) ; do
emake -C "${directory}" makefile.dep
done