summaryrefslogtreecommitdiff
path: root/net-analyzer/netio
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/netio')
-rw-r--r--net-analyzer/netio/Manifest3
-rw-r--r--net-analyzer/netio/files/netio-1.26-linux-include.patch10
-rw-r--r--net-analyzer/netio/netio-1.32-r1.ebuild48
3 files changed, 0 insertions, 61 deletions
diff --git a/net-analyzer/netio/Manifest b/net-analyzer/netio/Manifest
index edf1f633667d..e3af11fcc873 100644
--- a/net-analyzer/netio/Manifest
+++ b/net-analyzer/netio/Manifest
@@ -1,6 +1,3 @@
-AUX netio-1.26-linux-include.patch 195 BLAKE2B 4f6837a9194692658f82f50e3d3a59b4f815af2a0d32ec5d24f09c14e06cbf93a2f09e8d149dd9e65c58b41cc2bb55ff0beeb9c701304c37f6d1f95639678aca SHA512 719f65026c4d14b2f2252a9ca917fe7b46a1788d0ee84c763313f0e40fed7027c7e6d73de298735c05160f2ce0f08c8f5a49503369d3cd80d8ea26ce6c82263d
-DIST netio132.zip 162484 BLAKE2B 921b28d25a8042b5567393b088fbede3f8bff2d4bf6c8afcaab03a76487ddc48e6cd640b2cbe7114b022cacef9fcf5ccc3deaa9eed2b648898d7f2dfb40e133c SHA512 3473b6b41c4a1e054fa0eb3316bc16e799034b4b9402c7751f29724d8ec70c674d3de59140fdbdc301c53f2a24b44d58e8cd50a68f107bd892b1d17b6e695232
DIST netio133.zip 235931 BLAKE2B e664700b5991e38ad056333b13ba6ec40efd2a9a496dd9235ad40482b281f21ca54f49e037a0155d3ca0b1d77bd54330462d08abe5f809c6ee337b672c979995 SHA512 79a4d8ad5a5d9750a19bf7f8f4cc762e6d1a866a63138bfc1cf8614057eb8ade147817e489f93210990ce9d82be03a5053821663212fbee71c4cd46c2f9c9232
-EBUILD netio-1.32-r1.ebuild 908 BLAKE2B 6848f05e30ee341f3ac22754679a43a25312de4baa95560ead9cd0772524d4c176d68fdad39d163f2ae24947eabc30a261738d0b1710eea41306e2fa341a2d66 SHA512 5b07d36442551b989469ec86d6c51678d780363ebf6ee9803e5ce1a09e06d1e731548c2c78f32c411c662bee15c0dfe35d11bdaeff9909efd762384eece0ff3c
EBUILD netio-1.33.ebuild 811 BLAKE2B 35ea68531bbb37a529f736c481beb889759a529134bf59fe71ce3dc2db899c47d2658aaeeb8c4dc2f3583db0c1557a8308e6103ca10a046c3846223e622c52ee SHA512 1929b0356d9e9c67877f95e812b5773322ef6609a017199aee3317c59ec30f834af82ee2294ca2d7d60f370eb832f68b0fe274a9a2cb7cdb23d5ae5a02f866fc
MISC metadata.xml 276 BLAKE2B e21811549278e73aa9a14acfe242fd022106a39ac1300caa00615772d7f54d08a433052659a271f9ac0d453c7776fc2b9e8d86e6d3f637817c214174dde52cb2 SHA512 f0e6c6bc89659e01e157d9bf30d0a2f3fd2d71bc26c8d12489c4a44fc5237159946e25b46e7295ab4676aea63559194977a0b1e76aced31d81cf6387dd0f4250
diff --git a/net-analyzer/netio/files/netio-1.26-linux-include.patch b/net-analyzer/netio/files/netio-1.26-linux-include.patch
deleted file mode 100644
index 591cae323842..000000000000
--- a/net-analyzer/netio/files/netio-1.26-linux-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/netio.c
-+++ b/netio.c
-@@ -199,6 +199,7 @@
- #include <sys/time.h>
- #include <time.h>
- #include <netinet/in.h>
-+#include <arpa/inet.h>
- #include <netdb.h>
-
- #define psock_errno(x) perror(x)
diff --git a/net-analyzer/netio/netio-1.32-r1.ebuild b/net-analyzer/netio/netio-1.32-r1.ebuild
deleted file mode 100644
index a2016af62465..000000000000
--- a/net-analyzer/netio/netio-1.32-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils toolchain-funcs
-
-DESCRIPTION="measures net throughput with NetBIOS and TCP/IP protocols"
-HOMEPAGE="https://web.ars.de/netio/"
-SRC_URI="http://web.ars.de/wp-content/uploads/2017/04/${PN}${PV/./}.zip"
-
-LICENSE="free-noncomm"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-RESTRICT="mirror" # bug #391789 comment #1
-
-DEPEND="
- app-arch/unzip
- >=sys-apps/sed-4
-"
-
-S="${WORKDIR}"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.26-linux-include.patch
-)
-
-src_prepare() {
- edos2unix *.c *.h *.doc
-
- default
-
- sed -i \
- -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
- -e 's|\(CC\)=|\1?=|g' \
- -e 's|\(CFLAGS\)=|\1+=|g' \
- Makefile || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- linux
-}
-
-src_install() {
- dobin netio
- dodoc netio.doc
-}