summaryrefslogtreecommitdiff
path: root/net-analyzer/netdata/netdata-1.45.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/netdata/netdata-1.45.2.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-1.45.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-analyzer/netdata/netdata-1.45.2.ebuild b/net-analyzer/netdata/netdata-1.45.2.ebuild
index 2d2fe2aeb560..0d57f53917bc 100644
--- a/net-analyzer/netdata/netdata-1.45.2.ebuild
+++ b/net-analyzer/netdata/netdata-1.45.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python{3_9,3_10,3_11} )
-inherit cmake fcaps linux-info optfeature python-single-r1 systemd
+inherit cmake fcaps flag-o-matic linux-info optfeature python-single-r1 systemd
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
@@ -95,6 +95,14 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/927174
+ # https://github.com/netdata/netdata/issues/17321
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
-DCMAKE_INSTALL_PREFIX=/