summaryrefslogtreecommitdiff
path: root/net-analyzer/nbtscan
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nbtscan')
-rw-r--r--net-analyzer/nbtscan/Manifest3
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch15
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch42
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch119
4 files changed, 0 insertions, 179 deletions
diff --git a/net-analyzer/nbtscan/Manifest b/net-analyzer/nbtscan/Manifest
index 2fb5f348397b..e06cf1fba593 100644
--- a/net-analyzer/nbtscan/Manifest
+++ b/net-analyzer/nbtscan/Manifest
@@ -1,6 +1,3 @@
-AUX nbtscan-1.5.1-gentoo.patch 407 BLAKE2B bb761c5eab9b74d8988cae25ddb48662bab855c5ef4682acb29d4e4ca10f8fff4d3ef7d7495e1b684dc6c3d258197f32a04179c959184ea6ec8c7e8b6e994c1a SHA512 3bdfb90ac71eb599ec2eb3a8f83c3ba7d821da8cff9b5692aa03047f8212a88a9730c6ef3f20eb9aa250500aed5b49d287859be1d5b3fd4542a1cdb90c796d9b
-AUX nbtscan-1.5.1-includes-declarations.patch 954 BLAKE2B 7cbac59c29c3472fef5a87abee1bdd456f82dc5893777aaa0afce40d82aefdecefc53e60e822e9e9677a26315f645eee1069f8ac53cabda7eaa0a83361e4de02 SHA512 793499744b91621462802a6c53c1ba3e53de0537549b1f48047b81f7b34aeb1d1fa4b6dbe3c99048139061b05c2b5db19d9bbd9cb4a74c735a756dfb52843cc3
-AUX nbtscan-1.5.1-script-whitespace.patch 3784 BLAKE2B 3d8651982b85f1adc09726e90367ec40fd14db5480f5a96157ff379e54b955af0040d438fe78381284374c7574b803977d8f741616b90244740af33effe49c30 SHA512 38c7450809d876f347b17e3b60809ae408168766c2e8898f56495b33e158168e98b5d2f74208f2927af1dea68bf9956bde4bf3a0cbbceb21bae9dd8cee6ec3f6
DIST nbtscan-1.6.tar.gz 27290 BLAKE2B 3e38e946aa875be2bca8ad0155a5bf4c612cecda3761623d75657b2ab54aa7a7526d284a78db764518748e092c2719a4c02bcdce32095c87537c9979571c10f7 SHA512 b791357160ae7fe784ebf3b74df551c0b7dcaeefae2ddd585a9e5ac0fe7dd1bb32f00d2b898dcd700e74809708f42fc8e5f0022254e1282914b3f668564b4bcb
EBUILD nbtscan-1.6.ebuild 679 BLAKE2B 4296c0705c408a0e82eec941db81158cbfac55ae6169dd6bddef8246d06e942b5b486453945bd1dc3b854b1e347a717d9e2b8ae677dacb0c2c51f4c6abd04352 SHA512 a2e0970efa4336ecf9e71950d12b181042d9c4e7658cd51fbe3c6911ac26816fb1b7c0be459b3aafecbce91e4bbef37c94f0e48cc3dfaa47fd68fa65fdddf052
MISC metadata.xml 276 BLAKE2B e21811549278e73aa9a14acfe242fd022106a39ac1300caa00615772d7f54d08a433052659a271f9ac0d453c7776fc2b9e8d86e6d3f637817c214174dde52cb2 SHA512 f0e6c6bc89659e01e157d9bf30d0a2f3fd2d71bc26c8d12489c4a44fc5237159946e25b46e7295ab4676aea63559194977a0b1e76aced31d81cf6387dd0f4250
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch
deleted file mode 100644
index dbf2457bc29f..000000000000
--- a/net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -11,10 +11,10 @@
- BINDIR = @bindir@
-
- nbtscan: $(OBJECTS)
-- $(CC) $(CFLAGS) -o nbtscan $(OBJECTS) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o nbtscan $(OBJECTS) $(LIBS)
-
- install:
-- $(INSTALL) $(TARGET) $(BINDIR)/$(TARGET)
-+ $(INSTALL) $(TARGET) $(DESTDIR)/$(BINDIR)/$(TARGET)
-
- nbtscan.o: nbtscan.c statusq.h range.h list.h
- $(CC) $(CFLAGS) $(DEFS) -c nbtscan.c
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch
deleted file mode 100644
index a585d4495fb5..000000000000
--- a/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/list.h
-+++ b/list.h
-@@ -19,3 +19,5 @@
- int compare(struct list_item* item1, struct list_item* item2);
-
- int insert(struct list* lst, unsigned long content);
-+
-+int in_list(struct list* lst, unsigned long content);
---- a/nbtscan.c
-+++ b/nbtscan.c
-@@ -5,6 +5,8 @@
- #include <stdlib.h>
- #include <sys/time.h>
- #include <string.h>
-+#include <ctype.h>
-+#include <unistd.h>
- #if HAVE_STDINT_H
- #include <stdint.h>
- #endif
---- a/statusq.h
-+++ b/statusq.h
-@@ -103,4 +103,10 @@
- char* service_name;
- } nb_service_t ;
-
-+char* getnbservicename(my_uint8_t service, int unique, char* name);
-+
-+struct nb_host_info* parse_response(char* buff, int buffsize);
-+
-+int send_query(int sock, struct in_addr dest_addr, my_uint32_t rtt_base);
-+
- #endif /* STATUSQ_H */
---- a/statusq.c
-+++ b/statusq.c
-@@ -29,6 +29,7 @@
- #include <sys/time.h>
- #include "statusq.h"
- #include <string.h>
-+#include <ctype.h>
- #include <stdio.h>
- #include <stddef.h>
- #include "errors.h"
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch
deleted file mode 100644
index 4aca976dcd38..000000000000
--- a/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch
+++ /dev/null
@@ -1,119 +0,0 @@
---- a/nbtscan.c
-+++ b/nbtscan.c
-@@ -86,7 +86,7 @@
- int d_print_hostinfo(struct in_addr addr, const struct nb_host_info* hostinfo) {
- int i;
- unsigned char service; /* 16th byte of NetBIOS name */
-- char name[16];
-+ char comp_name[16];
-
- printf("\nPacket dump for Host %s:\n\n", inet_ntoa(addr));
- if(hostinfo->is_broken) printf("Incomplete packet, %d bytes long.\n", hostinfo->is_broken);
-@@ -110,9 +110,9 @@
- printf("Names received:\n");
- for(i=0; i< hostinfo->header->number_of_names; i++) {
- service = hostinfo->names[i].ascii_name[15];
-- strncpy(name, hostinfo->names[i].ascii_name, 15);
-- name[16]=0;
-- printf("%-17s Service: 0x%02x Flags: 0x%04x\n", name, service, hostinfo->names[i].rr_flags);
-+ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-+ comp_name[15]=0;
-+ printf("%-17s Service: 0x%02x Flags: 0x%04x\n", comp_name, service, hostinfo->names[i].rr_flags);
- }
- };
-
-@@ -147,9 +147,9 @@
-
-
- int v_print_hostinfo(struct in_addr addr, const struct nb_host_info* hostinfo, char* sf, int hr) {
-- int i, unique;
-+ int i, j, unique;
- my_uint8_t service; /* 16th byte of NetBIOS name */
-- char name[16];
-+ char comp_name[16];
- char* sname;
-
- if(!sf) {
-@@ -163,20 +163,27 @@
- if(hostinfo->header && hostinfo->names) {
- for(i=0; i< hostinfo->header->number_of_names; i++) {
- service = hostinfo->names[i].ascii_name[15];
-- strncpy(name, hostinfo->names[i].ascii_name, 15);
-- name[16]=0;
-+ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-+
-+ // Eliminate trailing spaces
-+ for(j=0; j < 15; j++) {
-+ if (comp_name[j] == ' ')
-+ break;
-+ }
-+ comp_name[j] = 0;
-+
- unique = !(hostinfo->names[i].rr_flags & 0x0080);
- if(sf) {
-- printf("%s%s%s%s", inet_ntoa(addr), sf, name, sf);
-- if(hr) printf("%s\n", (char*)getnbservicename(service, unique, name));
-+ printf("%s%s%s%s", inet_ntoa(addr), sf, comp_name, sf);
-+ if(hr) printf("%s\n", (char*)getnbservicename(service, unique, comp_name));
- else {
- printf("%02x", service);
- if(unique) printf("U\n");
- else printf("G\n");
- }
- } else {
-- printf("%-17s", name);
-- if(hr) printf("%s\n", (char*)getnbservicename(service, unique, name));
-+ printf("%-17s", comp_name);
-+ if(hr) printf("%s\n", (char*)getnbservicename(service, unique, comp_name));
- else {
- printf("<%02x>", service);
- if(unique) printf(" UNIQUE\n");
-@@ -199,7 +206,7 @@
- };
-
- int print_hostinfo(struct in_addr addr, struct nb_host_info* hostinfo, char* sf) {
-- int i;
-+ int i,j;
- unsigned char service; /* 16th byte of NetBIOS name */
- char comp_name[16], user_name[16];
- int is_server=0;
-@@ -215,7 +222,13 @@
- if(service == 0 && unique && first_name) {
- /* Unique name, workstation service - this is computer name */
- strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-- comp_name[15] = 0;
-+
-+ // Eliminate trailing spaces
-+ for(j=0; j < 15; j++) {
-+ if (comp_name[j] == ' ')
-+ break;
-+ }
-+ comp_name[j] = 0;
- first_name = 0;
- };
- if(service == 0x20 && unique) {
-@@ -252,7 +265,7 @@
- /* If l is true adds #PRE to each line of output (for lmhosts) */
-
- int l_print_hostinfo(struct in_addr addr, struct nb_host_info* hostinfo, int l) {
-- int i;
-+ int i,j;
- unsigned char service; /* 16th byte of NetBIOS name */
- char comp_name[16];
- int is_server=0;
-@@ -268,7 +281,13 @@
- if(service == 0 && unique && first_name) {
- /* Unique name, workstation service - this is computer name */
- strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-- comp_name[15]=0;
-+
-+ // Eliminate trailing spaces
-+ for(j=0; j < 15; j++) {
-+ if (comp_name[j] == ' ')
-+ break;
-+ }
-+ comp_name[j] = 0;
- first_name = 0;
- };
- };
-