summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-core
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-core')
-rw-r--r--net-analyzer/nagios-core/Manifest2
-rw-r--r--net-analyzer/nagios-core/nagios-core-4.4.5-r6.ebuild (renamed from net-analyzer/nagios-core/nagios-core-4.4.5-r5.ebuild)13
2 files changed, 6 insertions, 9 deletions
diff --git a/net-analyzer/nagios-core/Manifest b/net-analyzer/nagios-core/Manifest
index 47147a44c706..a5cdca6f7623 100644
--- a/net-analyzer/nagios-core/Manifest
+++ b/net-analyzer/nagios-core/Manifest
@@ -7,5 +7,5 @@ DIST nagios-4.4.5.tar.gz 11304463 BLAKE2B e1152c2cd14aa790fbdb84c0d7b3eb4691b057
DIST nagios-core-gentoo-icons-20141125.tar 40960 BLAKE2B 31c1953e1160c7c7b89606b72b1a80407e4c1b7a7938b40bd1c577cd0c309dd88ca6b775d692a9b846dbf67736537fa9c91e56aa15fdd447769608ca525bff09 SHA512 bf109879cddd6136b76baba55d0b60b2596e37431dcf5ce0905d34a9fa292ebf7e4bde82d9a084362c486e8fac344c76d88f9298b1b85541ed70ffd608493766
EBUILD nagios-core-4.3.4.ebuild 6633 BLAKE2B b179113b24ff38a5c147de20cd48db21fa1379f4ab377c7c354a1f107f9651f1b348f7dbd26825aaacb1fe8ce54d8feedbd7a44b65d3c897480d1c87a1fd4183 SHA512 43668b229464870ff2843790b1fd3bed7e3e2c4ba58f8cc19b90d8e85418c0e86b3b604089ccf52a63f24f6c0fb5e9ea4045769b2f63df96dc7d70c53d3e8411
EBUILD nagios-core-4.4.5-r3.ebuild 7470 BLAKE2B ceb783a9c27047b42b6464a2570452125f2ff6f5c7c6a3333a63f113b2c78037ca7cea1db6cd6ca783d58d3d4bfaa491fade7217bff29b76f2cbaa7496c74dc4 SHA512 4962381b6508363c2f330e81dd81d3de878cb7ef7428f8ba9fc71193c6a3de2c93c8c32298212312feaa72e76b0094fec7ff9e04a9f07072be8181c12497a82a
-EBUILD nagios-core-4.4.5-r5.ebuild 8080 BLAKE2B a7f849c7eac614e3f834a52440991a210e268f2462c5047cef127ec3e6f53af93e3b4e62d4a8b5ace9df3e5179e244593df0b072c9c7a19283792c2d0e3c1edb SHA512 2c2942cc48a7956708c6e0409941f98b3e4a3078af6df8c32adafce633d52dc3cace5f8df5a3240c8ca21c78d247885795f9c17f1dc1317186f75e01710124ec
+EBUILD nagios-core-4.4.5-r6.ebuild 8044 BLAKE2B 14761a831bb22669589931e9d66fc50907b6caab8fce0f06a26c0098d61d8261241037f4276ec8cfb87b957b2e5c28de59df4b6c83b773ed5e8112df8f758391 SHA512 cc0d4a90b62bbb6cc7a8bf04bbe388e07106241d98133aa5f345e332bab043b72a55dda194959161580ad9f47832e0490ae9cdefc3c5a5dedd76743ad36a1ada
MISC metadata.xml 1466 BLAKE2B 655e382c72b7fcf8f4283055a503e2ad79dbfc695f730980543e6a7381f5aa093ab279341cd2df19a1d5e5053b2c686ecf6884c541a7b984dce60fc1ae4d4599 SHA512 51f819fc2cbe3b87ee96b048fd0e622f78673a29d5b42b2b8f1d963f6f71ead679b057863f5f1a56e997c1e19ff26edf52697c02f79ba89ed6a5480d0ae2296b
diff --git a/net-analyzer/nagios-core/nagios-core-4.4.5-r5.ebuild b/net-analyzer/nagios-core/nagios-core-4.4.5-r6.ebuild
index a1922298fa0f..6ec6bb7044f5 100644
--- a/net-analyzer/nagios-core/nagios-core-4.4.5-r5.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-4.4.5-r6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs user
+inherit toolchain-funcs
MY_P=${PN/-core}-${PV}
DESCRIPTION="Nagios core - monitoring daemon, web GUI, and documentation"
@@ -47,7 +47,9 @@ REQUIRED_USE="apache2? ( !lighttpd )"
# extract a snapshot of AngularJS, but that's only needed when USE=web.
#
MOD_ALIAS=apache2_modules_alias
-DEPEND="dev-libs/libltdl:0
+DEPEND="acct-group/nagios
+ acct-user/nagios
+ dev-libs/libltdl:0
virtual/mailx
perl? ( dev-lang/perl:= )
web? (
@@ -70,11 +72,6 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- enewgroup nagios
- enewuser nagios -1 -1 -1 nagios
-}
-
src_configure() {
local myconf