summaryrefslogtreecommitdiff
path: root/net-analyzer/mtr/mtr-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mtr/mtr-9999.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild22
1 files changed, 6 insertions, 16 deletions
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 6185590ebe48..75a592ba00d8 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils fcaps flag-o-matic git-r3
+EAPI=7
+inherit autotools fcaps flag-o-matic git-r3
DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
-HOMEPAGE="http://www.bitwizard.nl/mtr/"
+HOMEPAGE="https://www.bitwizard.nl/mtr/"
EGIT_REPO_URI="https://github.com/traviscross/mtr"
-SRC_URI="mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -17,7 +16,7 @@ IUSE="gtk ipv6 ncurses"
RDEPEND="
gtk? (
dev-libs/glib:2
- x11-libs/gtk+:2
+ x11-libs/gtk+:3
)
ncurses? ( sys-libs/ncurses:0= )
"
@@ -26,26 +25,17 @@ DEPEND="
sys-devel/autoconf
virtual/pkgconfig
"
-
DOCS=( AUTHORS FORMATS NEWS README.md SECURITY TODO )
FILECAPS=( cap_net_raw usr/sbin/mtr-packet )
PATCHES=(
"${FILESDIR}"/${PN}-0.88-tinfo.patch
)
-
-src_unpack() {
- git-r3_src_unpack
- unpack ${A}
-}
+RESTRICT="test"
src_prepare() {
- # Keep this comment and following mv, even in case ebuild does not need
- # it: kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
- mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 || die #222909
-
default
- AT_M4DIR="." eautoreconf
+ eautoreconf
}
src_configure() {