summaryrefslogtreecommitdiff
path: root/net-analyzer/labrea/labrea-2.5_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/labrea/labrea-2.5_p1.ebuild')
-rw-r--r--net-analyzer/labrea/labrea-2.5_p1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/net-analyzer/labrea/labrea-2.5_p1.ebuild b/net-analyzer/labrea/labrea-2.5_p1.ebuild
index 5fc9881601f9..a47abfc9e1a0 100644
--- a/net-analyzer/labrea/labrea-2.5_p1.ebuild
+++ b/net-analyzer/labrea/labrea-2.5_p1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="'Sticky' Honeypot and IDS"
HOMEPAGE="http://labrea.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P/_p*}-stable-${PV/*_p}.tar.gz"
+S="${WORKDIR}/${P/_p/-stable-}"
LICENSE="GPL-2"
SLOT="0"
@@ -16,15 +18,15 @@ DEPEND="
net-libs/libpcap
>=dev-libs/libdnet-1.7
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"
+
DOCS=( AUTHORS ChangeLog README{,.first} TODO NEWS )
+
PATCHES=(
"${FILESDIR}"/${P/_p/-stable-}-incdir.patch
"${FILESDIR}"/${P/_p*}-pcap_open.patch
+ "${FILESDIR}"/${PN}-2.5-libdir.patch
)
-S=${WORKDIR}/${P/_p/-stable-}
src_prepare() {
default
@@ -32,6 +34,8 @@ src_prepare() {
# autotools will overwrite this with the generic version
mv INSTALL README.first || die
+ mv configure.{in,ac} || die
+
eautoreconf
}