summaryrefslogtreecommitdiff
path: root/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/knocker/knocker-0.7.1-r3.ebuild')
-rw-r--r--net-analyzer/knocker/knocker-0.7.1-r3.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/net-analyzer/knocker/knocker-0.7.1-r3.ebuild b/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
index 9731d03bf7b7..30d70e219a09 100644
--- a/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
+++ b/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit base toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Knocker is an easy to use security port scanner written in C"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://knocker.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc x86"
-DOCS=( AUTHORS BUGS ChangeLog NEWS README TO-DO )
+PATCHES=(
+ "${FILESDIR}"/${P}-fency.patch
+ "${FILESDIR}"/${P}-free.patch
+ "${FILESDIR}"/${P}-knocker_user_is_root.patch
+)
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-fency.patch \
- "${FILESDIR}"/${P}-free.patch \
- "${FILESDIR}"/${P}-knocker_user_is_root.patch
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TO-DO )
+src_configure() {
tc-export CC
+ default
}