summaryrefslogtreecommitdiff
path: root/net-analyzer/ippl/ippl-1.4.14-r6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ippl/ippl-1.4.14-r6.ebuild')
-rw-r--r--net-analyzer/ippl/ippl-1.4.14-r6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/ippl/ippl-1.4.14-r6.ebuild b/net-analyzer/ippl/ippl-1.4.14-r6.ebuild
new file mode 100644
index 000000000000..1cddf3d999fa
--- /dev/null
+++ b/net-analyzer/ippl/ippl-1.4.14-r6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
+HOMEPAGE="http://pltplp.net/ippl/"
+SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+BDEPEND="
+ virtual/yacc
+ sys-devel/flex"
+RDEPEND="acct-user/ippl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.14-noportresolve.patch
+ "${FILESDIR}"/${PN}-1.4.14-manpage.patch
+ "${FILESDIR}"/${PN}-1.4.14-privilege-drop.patch
+ "${FILESDIR}"/${PN}-1.4.14-includes.patch
+ "${FILESDIR}"/${PN}-1.4.14-format-warnings.patch
+ # bug #351287
+ "${FILESDIR}"/${PN}-1.4.14-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dosbin Source/ippl
+
+ insinto /etc
+ doins ippl.conf
+
+ doman Docs/{ippl.8,ippl.conf.5}
+ dodoc BUGS CREDITS HISTORY README TODO
+
+ newinitd "${FILESDIR}"/ippl.rc ippl
+}