summaryrefslogtreecommitdiff
path: root/net-analyzer/ipaudit/ipaudit-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ipaudit/ipaudit-1.1.ebuild')
-rw-r--r--net-analyzer/ipaudit/ipaudit-1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-analyzer/ipaudit/ipaudit-1.1.ebuild b/net-analyzer/ipaudit/ipaudit-1.1.ebuild
new file mode 100644
index 000000000000..bec71b59b5a9
--- /dev/null
+++ b/net-analyzer/ipaudit/ipaudit-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="IPAudit monitors network activity on a network by host, protocol and port"
+HOMEPAGE="https://ipaudit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/zlib:=
+ mysql? ( dev-db/mysql-connector-c:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_with mysql)
+}