summaryrefslogtreecommitdiff
path: root/net-analyzer/fwlogwatch/fwlogwatch-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/fwlogwatch/fwlogwatch-1.5-r1.ebuild')
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.5-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.5-r1.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.5-r1.ebuild
index ed6ff796ace8..31625bc428aa 100644
--- a/net-analyzer/fwlogwatch/fwlogwatch-1.5-r1.ebuild
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -64,9 +64,10 @@ src_configure() {
}
src_compile() {
+ # -std=gnu17 for bug #945298 (signal handlers)
emake \
CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
+ CFLAGS="${CFLAGS} -std=gnu17" \
LDFLAGS="${LDFLAGS}"
use nls && emake -C po
}