summaryrefslogtreecommitdiff
path: root/net-analyzer/dnstracer/dnstracer-1.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/dnstracer/dnstracer-1.10.ebuild')
-rw-r--r--net-analyzer/dnstracer/dnstracer-1.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/dnstracer/dnstracer-1.10.ebuild b/net-analyzer/dnstracer/dnstracer-1.10.ebuild
new file mode 100644
index 000000000000..733c4c9cc2d7
--- /dev/null
+++ b/net-analyzer/dnstracer/dnstracer-1.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Determines where a given nameserver gets its information from"
+HOMEPAGE="https://www.mavetju.org/unix/general.php"
+SRC_URI="https://www.mavetju.org/download/${P}.tar.bz2 -> ${P}.tar.gz"
+LICENSE="BSD-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux"
+
+BDEPEND="
+ dev-lang/perl
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9-argv0.patch
+)
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.8
+
+ dodoc CHANGES CONTACT README
+}