summaryrefslogtreecommitdiff
path: root/net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch')
-rw-r--r--net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch b/net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch
new file mode 100644
index 000000000000..525f03740dd9
--- /dev/null
+++ b/net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -51,11 +51,9 @@
+ if(cmake_build_type_tolower STREQUAL "debug")
+ message(STATUS "Build Type: Debug")
+ set(CMAKE_BUILD_TYPE "Debug")
+- set(CMAKE_C_FLAGS "-Wall -Werror -pedantic -O0 -g")
+ else()
+ message(STATUS "Build Type: Release")
+ set(CMAKE_BUILD_TYPE "Release")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror")
+ endif()
+
+ include_directories(