summaryrefslogtreecommitdiff
path: root/media-video/xvattr
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/xvattr')
-rw-r--r--media-video/xvattr/Manifest3
-rw-r--r--media-video/xvattr/files/xvattr-1.3-conflicting-types.patch42
-rw-r--r--media-video/xvattr/xvattr-1.3-r4.ebuild (renamed from media-video/xvattr/xvattr-1.3-r3.ebuild)3
3 files changed, 46 insertions, 2 deletions
diff --git a/media-video/xvattr/Manifest b/media-video/xvattr/Manifest
index 7b3c32867444..dbe2a275da53 100644
--- a/media-video/xvattr/Manifest
+++ b/media-video/xvattr/Manifest
@@ -1,5 +1,6 @@
+AUX xvattr-1.3-conflicting-types.patch 1676 BLAKE2B 22f421d1d8c73249042e2ae48af44bdfe4cc1e2dddefa4484905906d2f4ca3e9e4df9c61d2b507a7b2f4dba85dc2be1caf4b31c85c56fec6603acebdb67cdca9 SHA512 dc1886a274f44a5044f7c105a6d3b8ff718687bd643e191886ce7486c1449ec676e92714a497fdd98621fea009c2d15e24ed13d6535de3165a8baa855e14d350
AUX xvattr-1.3-gtk.patch 1255 BLAKE2B 471cfe05fbeaaa405771543d5c3b8900be848642724078a583321aa997b5e8c442894e6d2f6bf4ccb0eeed283f5f059b2be741c654c9a18f888034a105eb2eff SHA512 a81015dfa6c556d99e27765e9d793d1ab745925be212c8a3c21503ac73a6d7bbae5642e7cae067544578e7a1388968a354b759e72edcde1ccb0fa704c929e138
AUX xvattr-1.3-pod-encoding.patch 303 BLAKE2B 127fa43fe4ab6586d30d85a685d98038f226f54286147c98fc4fa738cc996c2bb802cf8fa962bb9143dfc506d64243b1d3f8af5218705b24f0f435fff85f3256 SHA512 84be4a336efa6caffbacf15f2b68ddb1d6b60cc8212593662194d7a7df5891c6d5cefcb28c25412471e5e943359e6c4f076b77f9c92d1a93e084597d39697484
DIST xvattr-1.3.tar.gz 82263 BLAKE2B 5e12c3001640c50294693eccf4e6b04c0e034634cc25a7be9e70dcd84c6da73e87be5a092ba4e9d9e5a70469d5018ac016d9812c2099bd68d35247ac6c522730 SHA512 f7b9f9f46961458be6aebfa5c40b28ab0757220ee5a20bcc3b635eaf6912afd7ca2ee9e9d0cfa1894e8ce6c97433e23f78f307fa216d16b5628b8b37202120a0
-EBUILD xvattr-1.3-r3.ebuild 696 BLAKE2B 200a1c5318b14179733f60bb5fb2255fff69c8323482d6ab709e89c774ddb07b5b9e30952435406006b54d4b508d15819a18bd055a805b55e32e703a4ec495a1 SHA512 1b813172e152136528dadec79da8a6699517fb9bf5d369b6de3193405ecf93c478e058077159d0f07722e9ddef00d7f7e3a98e06c0d572448ac705c7a4b77209
+EBUILD xvattr-1.3-r4.ebuild 740 BLAKE2B b1a865653ccb01caea4ee5402cfefe592282b9dbb5ddebe32cc9905e14b92e558f3daf633b6e009a2b5a8e157c2ee3df8c5ec024ca493c0bff99a1173a4c3df9 SHA512 6c403dcd37d54d86270c4e34307e6ce2329a94421675678870027d6435f42ca9e671d143ff9166c90b9fc93e9f6733e337647eafec27a8d8e20f4fc07b967b6b
MISC metadata.xml 220 BLAKE2B 6f39345ea8474519439cc9768baf57bf07c0d8051eba252c30638ce35f30f8cbd1ecb06f7448893fa72ab9338630c83211fd366d66136b6ed090558fb376982c SHA512 3a2781821a74f9512a2b1fa55c8982a23f880b96b1707fdedf129d37685c2793eefe75a8080afe2bac64ed44d5f24648e6a25e163f87fe76a2b6be76b995647a
diff --git a/media-video/xvattr/files/xvattr-1.3-conflicting-types.patch b/media-video/xvattr/files/xvattr-1.3-conflicting-types.patch
new file mode 100644
index 000000000000..595c90fbd46b
--- /dev/null
+++ b/media-video/xvattr/files/xvattr-1.3-conflicting-types.patch
@@ -0,0 +1,42 @@
+Fix incompatible pointers, GTK style
+Also, remove non-POSIX getopt declaration that conflitcts
+with musl
+https://bugs.gentoo.org/919367
+https://bugs.gentoo.org/945292
+--- a/gxvattr.c
++++ b/gxvattr.c
+@@ -256,7 +256,7 @@
+ label = gtk_label_new (xvattr[k].name);
+ if (!strcmp(xvattr[k].name, "XV_COLORKEY")) {
+ manipulator = gtk_color_selection_new();
+- set_color_widget(manipulator, cur_val);
++ set_color_widget(GTK_OBJECT(manipulator), cur_val);
+ property->controller = (GtkObject *) manipulator;
+ property->set_widget = set_color_widget;
+ if (xvattr[k].flags & XvSettable) {
+@@ -269,7 +269,7 @@
+ xvattr[k].max_value == 1) {
+ // boolean value, use check button
+ manipulator = gtk_check_button_new();
+- set_bool_widget(manipulator, cur_val);
++ set_bool_widget(GTK_OBJECT(manipulator), cur_val);
+ property->controller = (GtkObject *) manipulator;
+ property->set_widget = set_bool_widget;
+ if (xvattr[k].flags & XvSettable) {
+--- a/getopt.h
++++ b/getopt.h
+@@ -138,14 +138,7 @@
+ `getopt'. */
+
+ #if (defined __STDC__ && __STDC__) || defined __cplusplus
+-# ifdef __GNU_LIBRARY__
+-/* Many other libraries have conflicting prototypes for getopt, with
+- differences in the consts, in stdlib.h. To avoid compilation
+- errors, only prototype getopt for the GNU C library. */
+ extern int getopt (int __argc, char *const *__argv, const char *__shortopts);
+-# else /* not __GNU_LIBRARY__ */
+-extern int getopt ();
+-# endif /* __GNU_LIBRARY__ */
+
+ # ifndef __need_getopt
+ extern int getopt_long (int __argc, char *const *__argv, const char *__shortopts,
diff --git a/media-video/xvattr/xvattr-1.3-r3.ebuild b/media-video/xvattr/xvattr-1.3-r4.ebuild
index 7a16d54cbe19..23dc55d055f7 100644
--- a/media-video/xvattr/xvattr-1.3-r3.ebuild
+++ b/media-video/xvattr/xvattr-1.3-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,6 +26,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-gtk.patch
"${FILESDIR}"/${P}-pod-encoding.patch
+ "${FILESDIR}"/${P}-conflicting-types.patch
)
src_prepare() {