summaryrefslogtreecommitdiff
path: root/media-video/vlc/vlc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc/vlc-9999.ebuild')
-rw-r--r--media-video/vlc/vlc-9999.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 97191e56c23d..2eec388951d8 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2000-2020 Gentoo Authors
+# Copyright 2000-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -166,7 +166,7 @@ RDEPEND="
png? ( media-libs/libpng:0= )
projectm? (
media-fonts/dejavu
- media-libs/libprojectm
+ media-libs/libprojectm:0=
)
pulseaudio? ( media-sound/pulseaudio )
rdp? ( >=net-misc/freerdp-2.0.0_rc0:=[client(+)] )
@@ -185,7 +185,7 @@ RDEPEND="
>=media-libs/speex-1.2.0
media-libs/speexdsp
)
- srt? ( >=net-libs/srt-1.3.0 )
+ srt? ( >=net-libs/srt-1.4.2 )
ssl? ( net-libs/gnutls:= )
svg? (
gnome-base/librsvg:2
@@ -201,7 +201,7 @@ RDEPEND="
)
twolame? ( media-sound/twolame )
udev? ( virtual/udev )
- upnp? ( net-libs/libupnp:= )
+ upnp? ( net-libs/libupnp:=[ipv6] )
v4l? ( media-libs/libv4l:= )
vaapi? ( x11-libs/libva:=[drm,wayland?,X?] )
vdpau? ( x11-libs/libvdpau )
@@ -442,6 +442,12 @@ src_configure() {
# VLC now requires C++11 after commit 4b1c9dcdda0bbff801e47505ff9dfd3f274eb0d8
append-cxxflags -std=c++11
+ if use omxil; then
+ # bug #723006
+ # https://trac.videolan.org/vlc/ticket/24617
+ append-cflags -fcommon
+ fi
+
# FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
@@ -475,16 +481,16 @@ src_test() {
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
- if [[ -z ${ROOT} ]] && [[ -x "/usr/libexec/vlc/vlc-cache-gen" ]] ; then
- einfo "Running /usr/libexec/vlc/vlc-cache-gen on /usr/libexec/vlc/plugins/"
- "/usr/libexec/vlc/vlc-cache-gen" "/usr/libexec/vlc/plugins/"
+ if [[ -z "${ROOT}" ]] && [[ -x "${EROOT}/usr/libexec/vlc/vlc-cache-gen" ]] ; then
+ einfo "Running ${EROOT}/usr/libexec/vlc/vlc-cache-gen on ${EROOT}/usr/libexec/vlc/plugins/"
+ "${EROOT}/usr/libexec/vlc/vlc-cache-gen" "${EROOT}/usr/libexec/vlc/plugins/"
else
- ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"
- ewarn "Please run /usr/libexec/vlc/vlc-cache-gen manually"
+ ewarn "We cannot run vlc-cache-gen (most likely ROOT != /)"
+ ewarn "Please run ${EROOT}/usr/libexec/vlc/vlc-cache-gen manually"
ewarn "If you do not do it, vlc will take a long time to load."
fi
@@ -492,8 +498,8 @@ pkg_postinst() {
}
pkg_postrm() {
- if [[ -e /usr/libexec/vlc/plugins/plugins.dat ]]; then
- rm /usr/libexec/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
+ if [[ -e "${EROOT}"/usr/libexec/vlc/plugins/plugins.dat ]]; then
+ rm "${EROOT}"/usr/libexec/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
fi
xdg_pkg_postrm