summaryrefslogtreecommitdiff
path: root/media-video/vamps
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vamps')
-rw-r--r--media-video/vamps/Manifest3
-rw-r--r--media-video/vamps/files/vamps-0.99.2-musl.patch146
-rw-r--r--media-video/vamps/vamps-0.99.2-r2.ebuild3
3 files changed, 150 insertions, 2 deletions
diff --git a/media-video/vamps/Manifest b/media-video/vamps/Manifest
index f3bb6fce1a50..1d0140ea44a6 100644
--- a/media-video/vamps/Manifest
+++ b/media-video/vamps/Manifest
@@ -1,4 +1,5 @@
+AUX vamps-0.99.2-musl.patch 4004 BLAKE2B 3b1eb3f2d73e099fd8f5ae2b3a0a178fda261fe27679c4102dad6d35b9640626600386777efe2968321ba3b75f160db91764f937d147cf4feca15f9283a6943d SHA512 0a5c67457ca2403344eb497c1a440a25445565dc9bc1fd22d02852381f974c71686e1e08ea302aa4e8cf81cb20464f84dd02880266cff152002055438efebf46
AUX vamps-0.99.2-premature-eof.patch 1247 BLAKE2B bf59784ff369864d8110b7c65215b3cf5d2082e3b2deed4da617a2c554015e024711f29ccd039e059dc8644895e098358e0c0266b1b70e116ceb6b6f6acd9323 SHA512 9f6422a8583cfeaedf1f5fb97ccac44f9631af7498daccd172b85140b21705d2f80d1769fa994478e8353874a2a24ac9d26460adab1078b08465575460bcfb07
DIST vamps-0.99.2.tar.gz 47062 BLAKE2B cb42c5d10617db92b64d1f696f409e4c01521bf5adb3bc0c4aa14266124b987289deaad6b6c0b5cd6738ad6bcdb3ea3af0cfc0658350c017f73de094e00c651c SHA512 27d26a5b63982e3b68b69b6e4f739e93a8eff2ca2e433e07a1350cafe9733f0b6a684e6bc51bce97612bc85fef9d4bf4ea0e781e493b227896de4cce4cd4662b
-EBUILD vamps-0.99.2-r2.ebuild 634 BLAKE2B ca6265aaf4b6b3f255a8dd9d3c0da9cd740fd1e594c81a1bfcec92bcb3a341af47c11008c1101b72d5ee60ea21d69e5deeea35d16423b0a6de242e713cb0d62c SHA512 d3c8a164520d0f592de0d06d4fc3c02ce035e08c9e75035cc3580414454d38c83116ab6d5b2604f17b4e85f5e66878d208cb86efd1ba346c36f2ce3d40c23763
+EBUILD vamps-0.99.2-r2.ebuild 665 BLAKE2B 3f6583969f74b496153e6e44649c197893201855a68e7f5c921befa2f36341fb464faba44634495c0e4421209633a33c32b768a4ba01cca395426574dc57684f SHA512 3208eb8bd85b8a1f7f57836182b373dbb8992e28ecfd45aa90f227bb0d78823ee8fd7fe0dc5724dba53497ddf659bc9da48a5dd88185c350d85ee1141c7f995a
MISC metadata.xml 299 BLAKE2B 46eb82cd91337f6c6fd9ac3ff50618bc96a7a91ea70cce2c61790f6c7f35e47a8e9b1686c4b757cd7940bf1c24fc7029eda57f979ad8fc2614c1de69d32a5b4c SHA512 1277ad9618f15a992a83d3542f6198fc89362371bd8f30846df143d07dafb2a1ca694ff13d2f3a430e370697dc3863e112fd7d020d92d76a3cd4903e6d3b0e64
diff --git a/media-video/vamps/files/vamps-0.99.2-musl.patch b/media-video/vamps/files/vamps-0.99.2-musl.patch
new file mode 100644
index 000000000000..da7fa4b143a4
--- /dev/null
+++ b/media-video/vamps/files/vamps-0.99.2-musl.patch
@@ -0,0 +1,146 @@
+https://bugs.gentoo.org/832384
+--- a/vamps/requant.c
++++ b/vamps/requant.c
+@@ -188,21 +188,21 @@ int old_dc_pred, new_dc_pred;
+
+ // mpeg2 state
+ // seq header
+- static uint horizontal_size_value;
+- static uint vertical_size_value;
++ static unsigned int horizontal_size_value;
++ static unsigned int vertical_size_value;
+
+ // pic header
+- static uint picture_coding_type;
++ static unsigned int picture_coding_type;
+
+ // pic code ext
+- static uint f_code[2][2];
+- static uint intra_dc_precision;
+- static uint picture_structure;
+- static uint frame_pred_frame_dct;
+- static uint concealment_motion_vectors;
+- static uint q_scale_type;
+- static uint intra_vlc_format;
+- static uint alternate_scan;
++ static unsigned int f_code[2][2];
++ static unsigned int intra_dc_precision;
++ static unsigned int picture_structure;
++ static unsigned int frame_pred_frame_dct;
++ static unsigned int concealment_motion_vectors;
++ static unsigned int q_scale_type;
++ static unsigned int intra_vlc_format;
++ static unsigned int alternate_scan;
+
+ // error
+ static int validPicHeader;
+@@ -211,9 +211,9 @@ int old_dc_pred, new_dc_pred;
+ static int sliceError;
+
+ // slice or mb
+- static uint quantizer_scale;
+- static uint new_quantizer_scale;
+- static uint last_coded_scale;
++ static unsigned int quantizer_scale;
++ static unsigned int new_quantizer_scale;
++ static unsigned int last_coded_scale;
+ static int h_offset, v_offset;
+ static int mb_skip, mb_add;
+ static int mb_out;
+@@ -385,7 +385,7 @@ int old_dc_pred, new_dc_pred;
+ assert (wbuf >= owbuf);
+ #endif
+
+-static MINLINE void putbits(uint val, int n)
++static MINLINE void putbits(unsigned int val, int n)
+ {
+ assert(n < 32);
+ assert(!(val & (0xffffffffU << n)));
+@@ -418,7 +418,7 @@ static MINLINE void Refill_bits(void)
+ SEEKR(1)
+ }
+
+-static MINLINE void Flush_Bits(uint n)
++static MINLINE void Flush_Bits(unsigned int n)
+ {
+ assert(inbitcnt >= n);
+
+@@ -430,21 +430,21 @@ static MINLINE void Flush_Bits(uint n)
+ while (unlikely(inbitcnt < 24)) Refill_bits();
+ }
+
+-static MINLINE uint Show_Bits(uint n)
++static MINLINE unsigned int Show_Bits(unsigned int n)
+ {
+ return ((unsigned int)inbitbuf) >> (32 - n);
+ }
+
+-static MINLINE uint Get_Bits(uint n)
++static MINLINE unsigned int Get_Bits(unsigned int n)
+ {
+- uint Val = Show_Bits(n);
++ unsigned int Val = Show_Bits(n);
+ Flush_Bits(n);
+ return Val;
+ }
+
+-static MINLINE uint Copy_Bits(uint n)
++static MINLINE unsigned int Copy_Bits(unsigned int n)
+ {
+- uint Val = Get_Bits(n);
++ unsigned int Val = Get_Bits(n);
+ putbits(Val, n);
+ return Val;
+ }
+@@ -1656,13 +1656,13 @@ static MINLINE void slice_non_intra_DCT (int cur_block)
+ #endif
+ }
+
+-static void motion_fr_frame ( uint f_code[2] )
++static void motion_fr_frame ( unsigned int f_code[2] )
+ {
+ get_motion_delta (f_code[0]);
+ get_motion_delta (f_code[1]);
+ }
+
+-static void motion_fr_field ( uint f_code[2] )
++static void motion_fr_field ( unsigned int f_code[2] )
+ {
+ COPYBITS (bit_buf, bits, 1);
+ get_motion_delta (f_code[0]);
+@@ -1673,7 +1673,7 @@ static void motion_fr_field ( uint f_code[2] )
+ get_motion_delta (f_code[1]);
+ }
+
+-static void motion_fr_dmv ( uint f_code[2] )
++static void motion_fr_dmv ( unsigned int f_code[2] )
+ {
+ get_motion_delta (f_code[0]);
+ get_dmv ();
+@@ -1690,7 +1690,7 @@ static void motion_fr_conceal ( )
+ COPYBITS (bit_buf, bits, 1);
+ }
+
+-static void motion_fi_field ( uint f_code[2] )
++static void motion_fi_field ( unsigned int f_code[2] )
+ {
+ COPYBITS (bit_buf, bits, 1);
+
+@@ -1698,7 +1698,7 @@ static void motion_fi_field ( uint f_code[2] )
+ get_motion_delta (f_code[1]);
+ }
+
+-static void motion_fi_16x8 ( uint f_code[2] )
++static void motion_fi_16x8 ( unsigned int f_code[2] )
+ {
+ COPYBITS (bit_buf, bits, 1);
+
+@@ -1711,7 +1711,7 @@ static void motion_fi_16x8 ( uint f_code[2] )
+ get_motion_delta (f_code[1]);
+ }
+
+-static void motion_fi_dmv ( uint f_code[2] )
++static void motion_fi_dmv ( unsigned int f_code[2] )
+ {
+ get_motion_delta (f_code[0]);
+ get_dmv ();
diff --git a/media-video/vamps/vamps-0.99.2-r2.ebuild b/media-video/vamps/vamps-0.99.2-r2.ebuild
index ffc3f70d3a13..4a474fcebe4b 100644
--- a/media-video/vamps/vamps-0.99.2-r2.ebuild
+++ b/media-video/vamps/vamps-0.99.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${P}-premature-eof.patch"
+ "${FILESDIR}/${P}-musl.patch"
)
src_compile() {