summaryrefslogtreecommitdiff
path: root/media-video/totem
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/totem')
-rw-r--r--media-video/totem/Manifest4
-rw-r--r--media-video/totem/totem-43.0-r1.ebuild10
-rw-r--r--media-video/totem/totem-43.1.ebuild10
3 files changed, 20 insertions, 4 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index 6003a57476ff..c5051977a395 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -3,6 +3,6 @@ AUX 43.1-gst-inspect-sandbox.patch 1611 BLAKE2B 61afe90ea4a7b7f8452fc584bb8ad807
AUX b 638 BLAKE2B d9b4b6eef77e3f66a7ec3badfecbfcf79cf9f80ac44f6a8b49e5c3f35ab411e0a4b7529c68c1080831814f0ce518097333156737ebef581e7cdbd323bd207a28 SHA512 cb233420d0d20cf87c42f609cdf4053d81c27ee3321331484e7b644607a92f368838d6c1857bb2190f245e372a38e9094c1de6fed042f21df7dbdec9624c1780
DIST totem-43.0.tar.xz 2486304 BLAKE2B 3b43ad2cbf40472bff3b7369001b9b7784ef52244812d9aae493fffa99982a8f24770d0f5063f0b1f1fd320d6b2cec5e702ded9ccfaece51f7bdf9d862b96230 SHA512 b35d32ebadf4b9900ab234f07f8a7128edbc15593e1447c22f3c7a653fcbd4a2df9d45484e2decce5dd5ab67849fca1003a1ded338a0af0930b6560ee4f764ae
DIST totem-43.1.tar.xz 2545240 BLAKE2B 922991006540e04b6919e9d455e123f563703c0ef04575b7610b6a0369d4e7fd8583cc5e87f313e3c137d5231c9c598fa197c6d89ef2ffd3a334c3486f417148 SHA512 1cd6ccea8a6e379095d1974b095aa29d7c7d800028704d680300dffc4c69a8d60397cab10996ab1c2e8075be5f7ddbce1aa5207d63b1088d23a42d9cd597730f
-EBUILD totem-43.0-r1.ebuild 3005 BLAKE2B 6948e017da3add7c4961fb02163e050c94042228d6285f61f946d3f12412106beb46b9a0ca62c8a25179424fdef616c6ae8ca7269d653b70bf4489e1a1c84fea SHA512 e2652990bbdcd6768f6677147c9af780fca97841d470d195f1e99718c9e14ef0def101ef59b9abc8948551efee82db21724faaefc6af7456eec45f343e626751
-EBUILD totem-43.1.ebuild 2899 BLAKE2B fb20c7c6900e99f8b1ef5103b1fd7b555a7b8ee454f1494f0b1efbc05918e99436eea3faed3e82648c7348b45ba59b5b4a0295711010e14fd7bdc49dd188078c SHA512 355151886caca9ce4fd3f5faf395ca4a9b8acaa691c791105e4b7497d810f4036a49b2128c9fc2ca2e6ed33e8fb179d7afd35b9d0882ffddfbf457a5f3c80b55
+EBUILD totem-43.0-r1.ebuild 3225 BLAKE2B c350a550d89fc4e2d091ef1188121f4e068bdd8f194944cbfa507816b6ef3eaa7eb79a69545939fc93e4686f77d2ff8cdf382871858b4e78b742702a41767a9c SHA512 75f88b91b98d17281e76c0cf87867a594b23592abf1403f0ff80ec31b6693508e57fc3a78aaac6d588b513067229319c2346db134d376662a99e2d2573026954
+EBUILD totem-43.1.ebuild 3119 BLAKE2B 8d93190b1dc2f48414d7e7ffd956ce5eab6e02c10929effe00d1c57b2e209530a16b655fdee8a07d3be26aa51e6f19e843b543509a6bc5903ae4d1197a36a1d8 SHA512 e7a09daf75f42e1614028a20145538a7694e9ceaa157c17b2cf15139f9cc1a0c7925fd808a63c4fca02944341be83171ed32cd251f087b80aa75f3424c436b67
MISC metadata.xml 1144 BLAKE2B 93350ee033585bcb68019b5daed10bdb6fd3f436b234fe7a077695a230868b7733cad41dec152aaa44a2b61b6aea0c057c59896ebe84b8e9bbafbba4b0aecc27 SHA512 5ec35c0372f72d88b19502b561031387b3fa1421e5cd5c642350410918b3b538b4e55fb0cf6f1ee69442ddf3865680c747e70f5196c45c7c91ea708d68a2ad15
diff --git a/media-video/totem/totem-43.0-r1.ebuild b/media-video/totem/totem-43.0-r1.ebuild
index 500638a0f4ac..eaa24bc5629f 100644
--- a/media-video/totem/totem-43.0-r1.ebuild
+++ b/media-video/totem/totem-43.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -91,6 +91,13 @@ src_prepare() {
}
src_configure() {
+ local native_file="${T}"/meson.ini.local
+ # We don't want to run pylint tests. They're only for style.
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ pylint='pylint-falseified'
+ EOF
+
local emesonargs=(
-Dhelp=true
-Denable-easy-codec-installation=yes
@@ -101,6 +108,7 @@ src_configure() {
-Dprofile=default
-Dinspector-page=false
-Dgst-inspect=false
+ --native-file "${native_file}"
)
meson_src_configure
}
diff --git a/media-video/totem/totem-43.1.ebuild b/media-video/totem/totem-43.1.ebuild
index 4b083245da72..076f4daf18c0 100644
--- a/media-video/totem/totem-43.1.ebuild
+++ b/media-video/totem/totem-43.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -90,6 +90,13 @@ src_prepare() {
}
src_configure() {
+ local native_file="${T}"/meson.ini.local
+ # We don't want to run pylint tests. They're only for style.
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ pylint='pylint-falseified'
+ EOF
+
local emesonargs=(
-Dhelp=true
-Denable-easy-codec-installation=yes
@@ -100,6 +107,7 @@ src_configure() {
-Dprofile=default
-Dinspector-page=false
-Dgst-inspect=false
+ --native-file "${native_file}"
)
meson_src_configure
}