summaryrefslogtreecommitdiff
path: root/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch')
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
new file mode 100644
index 000000000000..7efe223460fc
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
@@ -0,0 +1,28 @@
+Index: subtitleripper/Makefile
+===================================================================
+--- subtitleripper.orig/Makefile
++++ subtitleripper/Makefile
+@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
+ # Target
+ subtitle2pgm: subtitle2pgm.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) $^ -o $@
++ @$(CC) $^ -o $@ $(LIBS)
+
+ subtitle2vobsub: subtitle2vobsub.o vobsub.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) $^ -o $@
++ @$(CC) $^ -o $@ $(LIBS)
+
+ srttool: srttool.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) -g $^ -o $@
++ @$(CC) -g $^ -o $@ $(LIBS)
+
+ vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) -g $^ -o $@
++ @$(CC) -g $^ -o $@ $(LIBS)
+
+ .PHONY: clean dist rpm
+ clean: