summaryrefslogtreecommitdiff
path: root/media-video/rav1e/rav1e-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/rav1e/rav1e-9999.ebuild')
-rw-r--r--media-video/rav1e/rav1e-9999.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/media-video/rav1e/rav1e-9999.ebuild b/media-video/rav1e/rav1e-9999.ebuild
index 3865291f3bed..536a25b8d5e9 100644
--- a/media-video/rav1e/rav1e-9999.ebuild
+++ b/media-video/rav1e/rav1e-9999.ebuild
@@ -3,21 +3,29 @@
EAPI=7
+CRATES=""
+
inherit cargo
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/xiph/rav1e.git"
inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/xiph/rav1e/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris ${CRATES})
+ "
+ KEYWORDS="~amd64"
fi
DESCRIPTION="The fastest and safest AV1 encoder"
HOMEPAGE="https://github.com/xiph/rav1e/"
-SRC_URI="$(cargo_crate_uris ${CRATES})"
-RESTRICT="mirror"
-LICENSE="BSD-2"
+RESTRICT=""
+LICENSE="BSD-2 Apache-2.0 MIT Unlicense"
SLOT="0"
-KEYWORDS=""
IUSE="+capi"
ASM_DEP=">=dev-lang/nasm-2.14"
@@ -28,6 +36,9 @@ src_unpack() {
if [[ "${PV}" == *9999* ]]; then
git-r3_src_unpack
cargo_live_src_unpack
+ else
+ default
+ cargo_src_unpack
fi
}