summaryrefslogtreecommitdiff
path: root/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild')
-rw-r--r--media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
deleted file mode 100644
index 3cefa5dab0e0..000000000000
--- a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils git-r3 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Command line media player for the Raspberry Pi"
-HOMEPAGE="https://github.com/popcornmix/omxplayer"
-EGIT_REPO_URI="https://github.com/popcornmix/omxplayer.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="X"
-
-RDEPEND="dev-libs/libpcre
- media-fonts/freefont
- || ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin )
- sys-apps/dbus
- sys-apps/fbset
- media-video/ffmpeg
- dev-libs/boost
- media-libs/freetype:2
- X? (
- x11-apps/xrefresh
- x11-apps/xset
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/Makefile-0_p20160217.patch \
- "${FILESDIR}"/fonts-path.patch
-
- cat > Makefile.include << EOF
-LIBS=-lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
-EOF
-
- tc-export CXX
-}
-
-src_compile() {
- emake omxplayer.bin
-}
-
-src_install() {
- dobin omxplayer omxplayer.bin
- dodoc README.md
-}