summaryrefslogtreecommitdiff
path: root/media-video/obs-studio/obs-studio-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/obs-studio/obs-studio-9999.ebuild')
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index c8ccd0308e53..481cfe79ce98 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -4,9 +4,11 @@
EAPI=7
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+LUA_COMPAT=( luajit )
+# Does not work with 3.8+ https://bugs.gentoo.org/754006
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 xdg-utils
+inherit cmake lua-single python-single-r1 xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -22,11 +24,14 @@ HOMEPAGE="https://obsproject.com"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex +ssl truetype v4l vlc"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+alsa fdk imagemagick jack lua nvenc pulseaudio python speex +ssl truetype v4l vlc"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
BDEPEND="
- luajit? ( dev-lang/swig )
+ lua? ( dev-lang/swig )
python? ( dev-lang/swig )
"
DEPEND="
@@ -58,7 +63,7 @@ DEPEND="
fdk? ( media-libs/fdk-aac:= )
imagemagick? ( media-gfx/imagemagick:= )
jack? ( virtual/jack )
- luajit? ( dev-lang/luajit:2 )
+ lua? ( ${LUA_DEPS} )
nvenc? ( >=media-video/ffmpeg-4[video_cards_nvidia] )
pulseaudio? ( media-sound/pulseaudio )
python? ( ${PYTHON_DEPS} )
@@ -74,6 +79,7 @@ DEPEND="
RDEPEND="${DEPEND}"
pkg_setup() {
+ use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
}
@@ -94,15 +100,15 @@ src_configure() {
-DWITH_RTMPS=$(usex ssl)
)
- if [ "${PV}" != "9999" ]; then
+ if [[ ${PV} != *9999 ]]; then
mycmakeargs+=(
-DOBS_VERSION_OVERRIDE=${PV}
)
fi
- if use luajit || use python; then
+ if use lua || use python; then
mycmakeargs+=(
- -DDISABLE_LUA=$(usex !luajit)
+ -DDISABLE_LUA=$(usex !lua)
-DDISABLE_PYTHON=$(usex !python)
-DENABLE_SCRIPTING=yes
)
@@ -110,11 +116,11 @@ src_configure() {
mycmakeargs+=( -DENABLE_SCRIPTING=no )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
#external plugins may need some things not installed by default, install them here
insinto /usr/include/obs/UI/obs-frontend-api
doins UI/obs-frontend-api/obs-frontend-api.h