summaryrefslogtreecommitdiff
path: root/media-video/ffmpeg/files/ffmpeg-6.1-opencl-parallel-gmake-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg/files/ffmpeg-6.1-opencl-parallel-gmake-fix.patch')
-rw-r--r--media-video/ffmpeg/files/ffmpeg-6.1-opencl-parallel-gmake-fix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/media-video/ffmpeg/files/ffmpeg-6.1-opencl-parallel-gmake-fix.patch b/media-video/ffmpeg/files/ffmpeg-6.1-opencl-parallel-gmake-fix.patch
new file mode 100644
index 000000000000..c7eef79f347a
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-6.1-opencl-parallel-gmake-fix.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/782553
+
+--- a/libavfilter/Makefile
++++ b/libavfilter/Makefile
+@@ -663,7 +663,7 @@ clean::
+ $(RM) $(CLEANSUFFIXES:%=libavfilter/dnn/%) $(CLEANSUFFIXES:%=libavfilter/opencl/%) \
+ $(CLEANSUFFIXES:%=libavfilter/vulkan/%)
+
+-OPENCL = $(subst $(SRC_PATH)/,,$(wildcard $(SRC_PATH)/libavfilter/opencl/*.cl))
++OPENCL = $(wildcard libavfilter/opencl/*.cl)
+ .SECONDARY: $(OPENCL:.cl=.c)
+ libavfilter/opencl/%.c: TAG = OPENCL
+ libavfilter/opencl/%.c: $(SRC_PATH)/libavfilter/opencl/%.cl