summaryrefslogtreecommitdiff
path: root/media-video/ffmpeg/ffmpeg-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 69bdf4e82bac..b0f173916123 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -70,7 +70,7 @@ FFMPEG_FLAG_MAP=(
+bzip2:bzlib cpudetection:runtime-cpudetect debug gcrypt gnutls gmp
+gpl hardcoded-tables +iconv libressl:libtls libxml2 lzma +network opencl
openssl +postproc samba:libsmbclient sdl:ffplay sdl:sdl2 vaapi vdpau
- X:xlib xcb:libxcb xcb:libxcb-shm xcb:libxcb-xfixes +zlib
+ X:xlib X:libxcb X:libxcb-shm X:libxcb-xfixes +zlib
# libavdevice options
cdio:libcdio iec61883:libiec61883 ieee1394:libdc1394 libcaca openal
opengl
@@ -254,8 +254,8 @@ RDEPEND="
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.4[${MULTILIB_USEDEP}]
)
- xcb? ( >=x11-libs/libxcb-1.4[${MULTILIB_USEDEP}] )
zeromq? ( >=net-libs/zeromq-4.1.6 )
zimg? ( >=media-libs/zimg-2.7.4:=[${MULTILIB_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
@@ -301,7 +301,6 @@ GPL_REQUIRED_USE="
x264? ( gpl )
x265? ( gpl )
xvid? ( gpl )
- X? ( !xcb? ( gpl ) )
)
"
REQUIRED_USE="