summaryrefslogtreecommitdiff
path: root/media-video/bino/bino-1.6.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/bino/bino-1.6.8.ebuild')
-rw-r--r--media-video/bino/bino-1.6.8.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/media-video/bino/bino-1.6.8.ebuild b/media-video/bino/bino-1.6.8.ebuild
index 0cdd8ab1a37c..d7bdc7c2def6 100644
--- a/media-video/bino/bino-1.6.8.ebuild
+++ b/media-video/bino/bino-1.6.8.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils xdg
+inherit autotools flag-o-matic qmake-utils xdg
DESCRIPTION="Stereoscopic and multi-display media player"
HOMEPAGE="https://bino3d.org/"
@@ -11,7 +11,7 @@ SRC_URI="https://bino3d.org/releases/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="debug doc lirc video_cards_nvidia"
RDEPEND="
@@ -30,6 +30,18 @@ DEPEND="${RDEPEND}"
BDEPEND="sys-devel/gettext
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.8-time-include.patch
+ "${FILESDIR}"/${PN}-1.6.8-respect-AR.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for AR patch
+ eautoreconf
+}
+
src_configure() {
if use video_cards_nvidia; then
append-cppflags "-I${ESYSROOT}/usr/include/NVCtrl"