summaryrefslogtreecommitdiff
path: root/media-video/asfrecorder/asfrecorder-1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/asfrecorder/asfrecorder-1.1-r2.ebuild')
-rw-r--r--media-video/asfrecorder/asfrecorder-1.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-video/asfrecorder/asfrecorder-1.1-r2.ebuild b/media-video/asfrecorder/asfrecorder-1.1-r2.ebuild
new file mode 100644
index 000000000000..4affdf5ebb9a
--- /dev/null
+++ b/media-video/asfrecorder/asfrecorder-1.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="${PN/asfr/ASFR}"
+
+DESCRIPTION="Linux WindowsMedia streaming client"
+HOMEPAGE="https://sourceforge.net/projects/asfrecorder/"
+SRC_URI="mirror://gentoo/${MY_PN}.zip"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-linux ~ppc-macos"
+
+BDEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-headers.patch
+)
+
+src_compile() {
+ tc-export CC
+ emake -C source ${PN}
+}
+
+src_install() {
+ dobin source/${PN}
+ einstalldocs
+}