summaryrefslogtreecommitdiff
path: root/media-video/2mandvd
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/2mandvd')
-rw-r--r--media-video/2mandvd/2mandvd-1.8.5.ebuild67
-rw-r--r--media-video/2mandvd/Manifest9
-rw-r--r--media-video/2mandvd/files/2mandvd-1.7.3-libav.patch10
-rw-r--r--media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch32
-rw-r--r--media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch21
-rw-r--r--media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch27
-rw-r--r--media-video/2mandvd/metadata.xml8
7 files changed, 174 insertions, 0 deletions
diff --git a/media-video/2mandvd/2mandvd-1.8.5.ebuild b/media-video/2mandvd/2mandvd-1.8.5.ebuild
new file mode 100644
index 000000000000..f272c5b4e872
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.8.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+LANGS="cs de en it ru"
+
+inherit qt4-r2
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug libav"
+
+DEPEND="libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ media-libs/libsdl
+ virtual/glu
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+"
+RDEPEND="${DEPEND}
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ dev-lang/perl
+ media-fonts/dejavu
+ media-gfx/exif
+ media-libs/netpbm
+ media-sound/sox
+ media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-video/mjpegtools
+ media-video/mplayer[encode]
+"
+
+S=${WORKDIR}/${MY_PN}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.3-libav.patch"
+ "${FILESDIR}/${PN}-1.8.5-libavformat54.patch"
+ "${FILESDIR}/${PN}-1.8.5-gcc6.patch"
+ "${FILESDIR}/${PN}-1.8.5-ffmpeg3.patch"
+)
+
+src_prepare() {
+ # Clean backup files
+ find . -name "*~" -delete || die
+
+ # Delete useless chmod that violates the sandbox
+ sed -i -e '/chmod/d' ${MY_PN}.pro || die
+
+ # Fix desktop file
+ sed -i -e '/^Categories=/s/GNOME;AudioVideo;//' ${MY_PN}.desktop || die
+
+ qt4-r2_src_prepare
+}
+
+pkg_postinst() {
+ elog "You may wish to install media-video/xine-ui and/or build"
+ elog "media-sound/sox with USE=mad for improved media handling support."
+}
diff --git a/media-video/2mandvd/Manifest b/media-video/2mandvd/Manifest
new file mode 100644
index 000000000000..ee1668f517ca
--- /dev/null
+++ b/media-video/2mandvd/Manifest
@@ -0,0 +1,9 @@
+AUX 2mandvd-1.7.3-libav.patch 269 SHA256 5c60fc260aca4a7c32e9a54646b8fae88eabbdc9a9fb8f867f2f81de62abefe5 SHA512 fc6d557ee3bf81f388f3f76b57a76364d1c68105d89391eaad74f2a429e1847d97a937c627ca28085dd3e9c12d9b882e0ffa68ffe9ba7b917faa9e952a8de0c5 WHIRLPOOL 8d95a4b78043d9026a06b8c292dcdc17f55569780b270de3ea0ec0d9b6181b8480b9d89bc0968d6d7bc6627e3581a96383848e784de52fb896e5cc911bc43d55
+AUX 2mandvd-1.8.5-ffmpeg3.patch 1469 SHA256 26667726c5cf7a006f313bda0a0a4ef6a98bec091bf29b32149dfd1ab692d824 SHA512 369a5eedb48b630b26e786bb1492047d59a76ab2e84c9c21230236253ccbf55ce36f4cc9a0b7aba214d7dcbfe567e183a50cea12b2b146f5a6599bc4d04c905d WHIRLPOOL 6ea49bbec47046e05a37e65a7d4f611c35c20d55cd15a8bf8eac157dabde21828328e6fa9d4cbfb8f7beb0f6cc19fc830a80943a68f29159aea55e9aadd0ecad
+AUX 2mandvd-1.8.5-gcc6.patch 531 SHA256 11162401a8059ce44802dbc2e2d9387c4226231d34f2dca7e318dff48f4c6c82 SHA512 8598d2ba4bdc10bcda46c86749e03647971ed517218ffea1c78d314351a53013ac28fd7755f9640e8601d9f0c360c352507d1a614ee7573cc4f8512f670a7d09 WHIRLPOOL 26ed1f018764db72dbce88f6e0cce5c1012b40fe69366c22be4be2d6edc80bb0f8d20032ad78a62ca5ded3ea1c2698eef0d925cbef4984b3ac0c9b17ea1afac4
+AUX 2mandvd-1.8.5-libavformat54.patch 819 SHA256 e4d662a31da92c83947f388cad545b1a592659911a7e8e11ee4399bbfff493ae SHA512 ff1500e95646966258890983a37abdd42eb4509d1bb084fd901cc9ab420be1108cb2b7fe3d3db1c92c453c8ae3a2ebc60218fe4994ca7f3fc91feaffcdc23b61 WHIRLPOOL 28aaef96fd9c4d6248a39289a2246ddfd447474753679329f9ce63fde2aaab60154c76974078c44127eddf120f7d1ea51720db11239b9a6c776920df0a8c2c7c
+DIST 2ManDVD-1.8.5.tar.gz 29525071 SHA256 19c3c02123684220e77b3baa12f37b6feb5ecb523c504c65d306c75136191873 SHA512 1e43034cab310ce0a642afdfcb2b4ddbc47b16b0f353adebd1fd2ec5f8445add41226390c6656e7cb520d9900e1b482adee7adb6f784d2fbfbaff2334feb3284 WHIRLPOOL 1a5b8e148fbfb2d7e67e18f64f15f560fe421e0f32d7f416ceea30a4b318f5078506d755df487be83032a7eb3279ced716a4122c215d5aed1bf69816f3a53f9f
+EBUILD 2mandvd-1.8.5.ebuild 1482 SHA256 5e116658b7d858ce0ebeeb93502396fee15c81aa28255f214b93d6b791a1b5b4 SHA512 81377876f32a2ada7f81731dbf6f9d0d93a6e0e3b23bff50b0da4498de229d8b1e8ec4bb156a78818b55dbbc26cf150ed28919d1bb2cc3ec7e653517575bac2a WHIRLPOOL e232b4a6bb04a36e30eab2ee24078b10359a26e2b28a2e7ab8b1bf7634e738e9b573af6cf7202e4ccd51e7e27e4990597d9eff4075e5670ef2fbefb25db295a3
+MISC ChangeLog 2737 SHA256 50cea1bf4e9ef82fce9e46ebd25e0d8c59441b4150fc7b718018c129302b0687 SHA512 7f5ec05a839d3fb5b5bfb36319830f7ce2edfc340b61afc6761f5175e76c73b99680c27f2aea7df1f9553b52c8e121cdb18e0b36f571001ac47ad59b5b6354b2 WHIRLPOOL 52eb5dd87d4432edee2d11e26a7517b5680cb889dfda07adb1b637087fee3a7971eca5a692eb86930b7d3d3251398a7ea3883dd13014b69fc1f4780163553b19
+MISC ChangeLog-2015 5670 SHA256 57cb4676c37b2a6e67f8d6a34e27a5294872a2208c2896b1a139a7a364003443 SHA512 87b575a53d84b6fc6b03178dcc524ce69229b6f026f5b664b1532bcc4439041768926fc21c0ac6ed1e458fbf3c1fa0d1f60274f5f37c0ae742d9ac0e20519da2 WHIRLPOOL 76011952ad47840d46f28b6beec894193cb3b00141b220fa748810f0b72dcabb9abf3fba0834c3ec578b7812dc306c17301290d077ba5956892e81695d3b409a
+MISC metadata.xml 243 SHA256 40d70720dcef790c8b2af5864ea1d289f0a661e0db1e89d2c6a8a5c0d2ea971e SHA512 fc40891d1d0c8526f7ac87f25fbdb63e927494f972894e0006fe85eab8eef60ae79761cbc42febd202172da040283a2daa432908bf02ef83d27454660f20e72b WHIRLPOOL 0c09ba0a23280f3d5b0bd26ca7e3f3fe8e43302780afbcb20218599b9b8f426485b8aba8c97f1507f9adab1688d78cb132792cb4d13e130454c393b69fc662f4
diff --git a/media-video/2mandvd/files/2mandvd-1.7.3-libav.patch b/media-video/2mandvd/files/2mandvd-1.7.3-libav.patch
new file mode 100644
index 000000000000..59dfd1e33a1e
--- /dev/null
+++ b/media-video/2mandvd/files/2mandvd-1.7.3-libav.patch
@@ -0,0 +1,10 @@
+--- videowrapper.h
++++ videowrapper.h
+@@ -11,6 +11,7 @@
+ #include <libavutil/common.h>
+ #include <libavcodec/avcodec.h>
+ #include <libavformat/avformat.h>
++ #include <libavutil/mathematics.h>
+ #include <libswscale/swscale.h>
+ }
+
diff --git a/media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch b/media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch
new file mode 100644
index 000000000000..29ffc95ffa82
--- /dev/null
+++ b/media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch
@@ -0,0 +1,32 @@
+Index: 2ManDVD/videowrapper.cpp
+===================================================================
+--- 2ManDVD.orig/videowrapper.cpp
++++ 2ManDVD/videowrapper.cpp
+@@ -99,11 +99,11 @@ int videowrapper::load_video(QString fil
+
+ img_convert_ctx = sws_getContext(pCodecCtx->width,
+ pCodecCtx->height, pCodecCtx->pix_fmt, pCodecCtx->width,
+- pCodecCtx->height, PIX_FMT_RGB24, SWS_BICUBIC, NULL,
++ pCodecCtx->height, AV_PIX_FMT_RGB24, SWS_BICUBIC, NULL,
+ NULL, NULL);
+
+ // *** ON DETERMINE LA TAILLE DU BUFFER ***
+- numBytes=avpicture_get_size(PIX_FMT_RGB24, pCodecCtx->width,
++ numBytes=avpicture_get_size(AV_PIX_FMT_RGB24, pCodecCtx->width,
+ pCodecCtx->height);
+ buffer=(uint8_t *)av_malloc(numBytes*sizeof(uint8_t));
+ old_frame = -1;
+@@ -120,10 +120,10 @@ QImage videowrapper::read_frame(int64_t
+ if ( num_frame != old_frame )
+ {
+ // *** ALLOCATE VIDEO FRAME ***
+- pFrameRGB=avcodec_alloc_frame();
+- pFrame=avcodec_alloc_frame();
++ pFrameRGB=av_frame_alloc();
++ pFrame=av_frame_alloc();
+
+- avpicture_fill((AVPicture *)pFrameRGB, buffer, PIX_FMT_RGB24,
++ avpicture_fill((AVPicture *)pFrameRGB, buffer, AV_PIX_FMT_RGB24,
+ pCodecCtx->width, pCodecCtx->height);
+ av_seek_frame(pFormatCtx,videoStream,0, AVSEEK_FLAG_FRAME);
+ compte_frame = -1;
diff --git a/media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch b/media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch
new file mode 100644
index 000000000000..5a16d95ef17f
--- /dev/null
+++ b/media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch
@@ -0,0 +1,21 @@
+Index: 2ManDVD/tetrahedron.h
+===================================================================
+--- 2ManDVD.orig/tetrahedron.h
++++ 2ManDVD/tetrahedron.h
+@@ -83,7 +83,6 @@ public:
+ float scale_factor;
+ float wg_x;
+ float wdecal;
+- GLfloat light_position[];
+
+ GLfloat anag_x;
+ GLfloat anag_y;
+@@ -427,6 +426,8 @@ private:
+ void dropEvent(QDropEvent *);
+ void dragEnterEvent(QDragEnterEvent *);
+ Qt::DropActions supportedDropActions () const;
++public:
++ GLfloat light_position[];
+ };
+
+ #endif
diff --git a/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch b/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch
new file mode 100644
index 000000000000..89ecc4d23c60
--- /dev/null
+++ b/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch
@@ -0,0 +1,27 @@
+diff --git a/videowrapper.cpp b/videowrapper.cpp
+index 7ae4ad3..d50599b 100644
+--- a/videowrapper.cpp
++++ b/videowrapper.cpp
+@@ -38,7 +38,7 @@ void videowrapper::delete_videowrapper()
+ int videowrapper::load_video(QString filename)
+ {
+ // *** OUVERTURE DU FICHIER VIDEO ***
+- #ifdef avformat_open_input
++ #if LIBAVFORMAT_VERSION_INT > AV_VERSION_INT(53,5,0)
+ if (avformat_open_input(&pFormatCtx,filename.toAscii().data(),NULL,NULL)!=0)
+ {
+ #else
+@@ -91,13 +91,8 @@ int videowrapper::load_video(QString filename)
+
+ // *** OUVERTURE DU CODEC ***
+
+- #ifdef av_find_stream_info
+- if(avcodec_open(pCodecCtx, pCodec)<0)
+- {
+- #else
+ if (avcodec_open2(pCodecCtx, pCodec, NULL) < 0)
+ {
+- #endif
+ qDebug() << "CAN'T FIND VIDEO CODEC";
+ return 1;
+ }
diff --git a/media-video/2mandvd/metadata.xml b/media-video/2mandvd/metadata.xml
new file mode 100644
index 000000000000..32fe1293e9a9
--- /dev/null
+++ b/media-video/2mandvd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+</maintainer>
+</pkgmetadata>