summaryrefslogtreecommitdiff
path: root/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild')
-rw-r--r--media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
new file mode 100644
index 000000000000..b73c3a00017f
--- /dev/null
+++ b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="VDR script: generate shoutcast playlists"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=19478"
+SRC_URI="http://www.kost.sh/vdr/${P}.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-video/vdr"
+
+S="${WORKDIR}"
+
+PLAYLIST_DIR="/var/cache/vdr/music/playlists"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ sed -i shoutcast2vdr-0.0.8 -e "s:outputdir=/home/volker/vdr/radio:outputdir=${PLAYLIST_DIR}:"
+}
+
+src_install() {
+
+ exeinto /usr/share/vdr/shoutcast2vdr
+ newexe shoutcast2vdr-0.0.8 shoutcast2vdr
+
+ keepdir ${PLAYLIST_DIR}
+}