summaryrefslogtreecommitdiff
path: root/media-sound/xwax
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/xwax')
-rw-r--r--media-sound/xwax/Manifest2
-rw-r--r--media-sound/xwax/xwax-1.8.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/media-sound/xwax/Manifest b/media-sound/xwax/Manifest
index a9702e4400d8..c994c67d6466 100644
--- a/media-sound/xwax/Manifest
+++ b/media-sound/xwax/Manifest
@@ -1,4 +1,6 @@
AUX xwax-etc-security-limits.conf 18 BLAKE2B 7056521164d62b76e2cba2b7a128a160364ac191af87185e99d5ecaa951c125938b66d4f1928d3b13794e5f1be4446b0b8ee8eed1e2a0c92e25edc0582b38264 SHA512 fab914f078597e9c4ba4ffa289f559106d62354d5f97c0847855c08cd8a9a1bdfd9db3f74d9b3868e6150d39fadc4c2c8d51b4815bb6b19ccdbee1fb6ddf72e2
DIST xwax-1.7.tar.gz 80745 BLAKE2B b431951651b66899b5bcceadfadc546c564123e47632aa9b395c26d706fc37cda4b5bf4f8695538e1a5e2bb0a690f125ca89705259d11df580f6a833e5d114b6 SHA512 ab0fcaf32f1fd1d6b38323095524f1932a067a3d04d40e4b043993e360411fed0c4b78bb71662581b438cb1e3005bc21659db4521a6ec704994b2e8e1b7e62d4
+DIST xwax-1.8.tar.gz 86268 BLAKE2B 7fbde34e6c1a3508da6ea8230cec7d2663503882182e403bf9bbf2b7327248c1b2e38a21392615a359d30d4a65f558e55346f99bf8f89621a18bcf9e8cf09139 SHA512 db37a16ecc5437f9b085c17e5e645e04b76a18aa7f7d8e8448a2994435596394ea7f2b52a6734194be7cf0b7099995f0f8735c2c547f3f57525339c4dc671d9d
EBUILD xwax-1.7-r1.ebuild 1977 BLAKE2B 1d54913f2c3e018371d8a4b2b5c9a19d5e9fd044e256b4fb8273666f66200ed6796c431a831c856b3aeb548c3b7e8b26a1118b77218f5c644eb487c2227af319 SHA512 c6c989d648d059aa011a031842c7d3a007b2d139a83165c5f82df7c960fe00c33a1e48bfad32bce549c4ff4c63e6f7853e79e1772696fdae91a219b679709dd9
+EBUILD xwax-1.8.ebuild 1981 BLAKE2B 9f534a9bcafafff0e66ca09030f05bdf917adcb10693d37d1638e53c3a295a8b42add98691e1c350841830059dbe78caf35e0752402a09dc1161f4e38813d2d1 SHA512 f967b41799f4dfbc7756ebd7421fb9ee5c6a11376e213278f0e3ae4cc6df851e0aaf6e672fb0404cd0facbec4525a15c0a6cf40ccc2c9432f3b4f6821f8a4815
MISC metadata.xml 705 BLAKE2B 0c5c6a1538fbe0faef37eac4c62ac8e806041e1dc2883b4341981e75e8829da8af4588f371215794e40a452b7178a538489abd4a1b211233370b85cdded4d9eb SHA512 39e87e361947199009b2b9c0d722418d21181d330f503e9fae493c6b7300e5ef287b78a2ef609e3084719c51de57cfe536e7ae726eae257b967871422639c54c
diff --git a/media-sound/xwax/xwax-1.8.ebuild b/media-sound/xwax/xwax-1.8.ebuild
new file mode 100644
index 000000000000..8c74789b19ce
--- /dev/null
+++ b/media-sound/xwax/xwax-1.8.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Digital vinyl emulation software"
+HOMEPAGE="https://xwax.org/"
+SRC_URI="https://xwax.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa jack oss cdda mp3 +fallback"
+
+REQUIRED_USE="
+ || ( cdda mp3 fallback )
+ || ( alsa jack oss )
+"
+
+DEPEND="
+ media-fonts/dejavu
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ sys-libs/glibc
+ sys-libs/pam
+ alsa? ( media-libs/alsa-lib )
+ cdda? ( media-sound/cdparanoia )
+ fallback? ( media-video/ffmpeg )
+ jack? ( virtual/jack )
+ mp3? ( media-sound/mpg123 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ acct-group/xwax
+"
+
+DOCS=( README CHANGES )
+
+src_prepare() {
+ default
+ # Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
+ # the Makefile
+ # Also remove the dependency on the .version target so we don't need
+ # git just to build
+ sed -i -e 's/\(^\(LD\|C\)FLAGS.*\)-O[0-9]\(.*\)/\1\3/g' \
+ -e 's/^xwax\.o:.*\.version//' \
+ Makefile || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ --prefix "${EPREFIX}/usr" \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable oss)
+}
+
+src_compile() {
+ # EXECDIR is the default directory in which xwax will look for
+ # the 'xwax-import' and 'xwax-scan' scripts
+ emake EXECDIR="\$(BINDIR)" VERSION="${PV}" xwax
+}
+
+src_install() {
+ # This is easier than setting all the environment variables
+ # needed, running the sed script required to get the man directory
+ # correct, and removing the GPL-2 after a 'make install' run
+ dobin xwax
+ newbin scan xwax-scan
+ newbin import xwax-import
+ doman xwax.1
+
+ dodoc ${DOCS}
+
+ insinto "/etc/security/limits.d"
+ newins "${FILESDIR}/xwax-etc-security-limits.conf" xwax.conf
+}
+
+pkg_postinst() {
+ elog "Be sure to add any users that will be using ${PN} to the"
+ elog "\"${PN}\" group. Doing so will allow processes that user"
+ elog "runs to request realtime priority."
+}