summaryrefslogtreecommitdiff
path: root/media-sound/umix/umix-1.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/umix/umix-1.0.2-r1.ebuild')
-rw-r--r--media-sound/umix/umix-1.0.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/umix/umix-1.0.2-r1.ebuild b/media-sound/umix/umix-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..8af3d98d5b02
--- /dev/null
+++ b/media-sound/umix/umix-1.0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Program for adjusting soundcard volumes"
+HOMEPAGE="http://umix.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="ncurses oss"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.2:= )"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+DOCS=(
+ AUTHORS ChangeLog NEWS README TODO
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ncurses || myconf="--disable-ncurses"
+ use oss || myconf="${myconf} --disable-oss"
+ econf ${myconf}
+}