summaryrefslogtreecommitdiff
path: root/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild')
-rw-r--r--media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild b/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild
new file mode 100644
index 000000000000..6630dbac467e
--- /dev/null
+++ b/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Wrapper around the Spotify client that adds a tray icon"
+HOMEPAGE="https://github.com/tsmetana/spotify-tray"
+SRC_URI="https://github.com/tsmetana/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}
+ media-sound/spotify
+"
+
+src_prepare() {
+ default
+ # Fix error: AM_INIT_AUTOMAKE expanded multiple times
+ sed -i -e '/^AM_INIT_AUTOMAKE$/d' configure.ac || die
+
+ # Fix the name of the icon
+ sed -i -e 's/Icon=spotify/Icon=spotify-client/g' spotify-tray.desktop.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # remove desktop file, launching is handled in spotify ebuild
+ rm "${ED}/usr/share/applications/spotify-tray.desktop" || die
+
+ # move executable outside of PATH to avoid accidentally launching it in a loop
+ mkdir -p "${ED}/opt/spotify/spotify-client" || die
+ mv "${ED}/usr/bin/spotify-tray" "${ED}/opt/spotify/spotify-client/spotify-tray" || die
+}