summaryrefslogtreecommitdiff
path: root/media-sound/snapcast/files/snapcast-0.25.0-cxx17.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/snapcast/files/snapcast-0.25.0-cxx17.patch')
-rw-r--r--media-sound/snapcast/files/snapcast-0.25.0-cxx17.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/snapcast/files/snapcast-0.25.0-cxx17.patch b/media-sound/snapcast/files/snapcast-0.25.0-cxx17.patch
new file mode 100644
index 000000000000..f6797a62f85f
--- /dev/null
+++ b/media-sound/snapcast/files/snapcast-0.25.0-cxx17.patch
@@ -0,0 +1,27 @@
+https://gitlab.exherbo.org/exherbo/media/-/blob/master/packages/net-apps/snapcast/files/snapcast-Set-CMAKE_CXX_STANDARD-to-17.patch
+
+From 9858c60109c5d4aa09c26d1cb44be5c056849a36 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Fri, 15 Oct 2021 23:55:39 +0200
+Subject: [PATCH] Set CMAKE_CXX_STANDARD to 17
+
+Fixes the build with boost[>=1.77.0] and we shouldn't have compilers
+which don't support it.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4381a71c..5373f658 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -127,7 +127,7 @@ if(NOT ANDROID)
+ endif()
+
+ # Configure compiler options
+-set(CMAKE_CXX_STANDARD 14)
++set(CMAKE_CXX_STANDARD 17)
+
+ # Get arch
+ include(${CMAKE_SOURCE_DIR}/cmake/TargetArch.cmake)
+