summaryrefslogtreecommitdiff
path: root/media-sound/shnflacverify/shnflacverify-0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/shnflacverify/shnflacverify-0.3-r1.ebuild')
-rw-r--r--media-sound/shnflacverify/shnflacverify-0.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/shnflacverify/shnflacverify-0.3-r1.ebuild b/media-sound/shnflacverify/shnflacverify-0.3-r1.ebuild
new file mode 100644
index 000000000000..a0e70430e399
--- /dev/null
+++ b/media-sound/shnflacverify/shnflacverify-0.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edos2unix
+
+DESCRIPTION="Manage the verification of checksums related to Shorten and FLAC files"
+HOMEPAGE="https://sourceforge.net/projects/shnflacverify/"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${P}/${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="
+ dev-lang/perl
+ media-libs/flac
+ media-sound/shntool
+ sys-apps/coreutils
+"
+
+src_prepare() {
+ default
+
+ edos2unix *.txt
+
+ local X
+ for X in flac md5sum shntool metaflac; do
+ einfo "setting \$${X}_cmd to $(type -p ${X})"
+ sed -i -e "s|^\(\$${X}_cmd\s*=\s*'\)[^']*\('.*\)|\1$(type -p ${X})\2|g" shnflac* || die
+ done
+}
+
+src_install() {
+ local X
+ for X in *.pl; do newbin "${X}" "${X%.*}"; done
+ newdoc README.txt README
+}