summaryrefslogtreecommitdiff
path: root/media-sound/scream/scream-3.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/scream/scream-3.8.ebuild')
-rw-r--r--media-sound/scream/scream-3.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/scream/scream-3.8.ebuild b/media-sound/scream/scream-3.8.ebuild
new file mode 100644
index 000000000000..82133a82fe29
--- /dev/null
+++ b/media-sound/scream/scream-3.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Plays sound received from network or from a QEMU Windows VM"
+HOMEPAGE="https://github.com/duncanthrax/scream"
+S="${WORKDIR}/${P}/Receivers/unix"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/duncanthrax/scream.git"
+else
+ SRC_URI="https://github.com/duncanthrax/scream/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Ms-PL"
+SLOT="0"
+IUSE="alsa jack pcap pulseaudio"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ jack? (
+ media-libs/soxr
+ virtual/jack
+ )
+ pcap? ( net-libs/libpcap )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DALSA_ENABLE=$(usex alsa)
+ -DJACK_ENABLE=$(usex jack)
+ -DPCAP_ENABLE=$(usex pcap)
+ -DPULSEAUDIO_ENABLE=$(usex pulseaudio)
+ )
+ cmake_src_configure
+}