summaryrefslogtreecommitdiff
path: root/media-sound/sc2mpd/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/sc2mpd/files')
-rw-r--r--media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch64
-rw-r--r--media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch72
2 files changed, 0 insertions, 136 deletions
diff --git a/media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch b/media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch
deleted file mode 100644
index d4103a522451..000000000000
--- a/media-sound/sc2mpd/files/sc2mpd-1.1.7-python.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -ur work.orig/ohNet/bundle_binaries.py work/ohNet/bundle_binaries.py
---- a/openhome/ohNet/bundle_binaries.py 2020-11-10 00:24:29.640122646 -0600
-+++ b/openhome/ohNet/bundle_binaries.py 2020-11-10 00:26:38.441470487 -0600
-@@ -121,22 +121,22 @@
- parser.add_option("-m", "--managed-only", default=False, action="store_true", help="Package only the managed assembly.")
- options, args = parser.parse_args()
- if len(args)>0:
-- print "Too many arguments."
-+ print("Too many arguments.")
- sys.exit(1)
- if options.system not in ALL_SYSTEMS:
-- print "Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS)))
-+ print("Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS))))
- sys.exit(1)
- if options.architecture not in ALL_ARCHITECTURES:
-- print "Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system))))
-+ print("Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system)))))
- sys.exit(1)
- if options.configuration not in ALL_CONFIGURATIONS:
-- print "Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS)))
-+ print("Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS))))
- sys.exit(1)
- target = BuildTarget(options.system, options.architecture, options.configuration)
- if target not in ALL_TARGETS:
-- print "Unrecognized target combination. Valid combinations are:"
-+ print("Unrecognized target combination. Valid combinations are:")
- for valid_target in sorted(ALL_TARGETS.keys()):
-- print " " + get_target_as_option_string(valid_target)
-+ print(" " + get_target_as_option_string(valid_target))
- sys.exit(1)
-
- buildinfo = ALL_TARGETS[target]
-diff -ur work.orig/ohNetGenerated/bundle_binaries.py work/ohNetGenerated/bundle_binaries.py
---- a/openhome/ohNetGenerated/bundle_binaries.py 2020-11-10 00:24:29.847123204 -0600
-+++ b/openhome/ohNetGenerated/bundle_binaries.py 2020-11-10 00:26:11.793398395 -0600
-@@ -96,22 +96,22 @@
- parser.add_option("-m", "--managed-only", default=False, action="store_true", help="Package only the managed assembly.")
- options, args = parser.parse_args()
- if len(args)>0:
-- print "Too many arguments."
-+ print("Too many arguments.")
- sys.exit(1)
- if options.system not in ALL_SYSTEMS:
-- print "Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS)))
-+ print("Please specify --system from one of {0}.".format(", ".join(sorted(ALL_SYSTEMS))))
- sys.exit(1)
- if options.architecture not in ALL_ARCHITECTURES:
-- print "Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system))))
-+ print("Please specify --architecture from one of {0}.".format(", ".join(sorted(set(tgt.architecture for tgt in ALL_TARGETS.keys() if tgt.system == options.system)))))
- sys.exit(1)
- if options.configuration not in ALL_CONFIGURATIONS:
-- print "Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS)))
-+ print("Please specify --configuration from one of {0}.".format(", ".join(sorted(ALL_CONFIGURATIONS))))
- sys.exit(1)
- target = BuildTarget(options.system, options.architecture, options.configuration)
- if target not in ALL_TARGETS:
-- print "Unrecognized target combination. Valid combinations are:"
-+ print("Unrecognized target combination. Valid combinations are:")
- for valid_target in sorted(ALL_TARGETS.keys()):
-- print " " + get_target_as_option_string(valid_target)
-+ print(" " + get_target_as_option_string(valid_target))
- sys.exit(1)
-
- buildinfo = ALL_TARGETS[target]
diff --git a/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch b/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch
deleted file mode 100644
index fd079e26fb8a..000000000000
--- a/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-diff -ur ohNet/Makefile ohNet/Makefile
---- a/openhome/ohNet/Makefile 2020-11-09 23:46:21.295605850 -0600
-+++ b/openhome/ohNet/Makefile 2020-11-09 23:48:05.977868337 -0600
-@@ -344,13 +344,13 @@
- cflags_base = -fexceptions -Wall $(version_specific_cflags_third_party) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) -fvisibility=hidden $(platform_cflags)
- cflags_third_party = $(cflags_base) -Wno-int-to-pointer-cast
- ifeq ($(nocpp11), yes)
-- cppflags = $(cflags_base) -Werror
-+ cppflags = $(cflags_base)
- else ifeq ($(platform),IntelMac)
-- cppflags = $(cflags_base) -std=c++11 -Werror
-+ cppflags = $(cflags_base) -std=c++11
- else
-- cppflags = $(cflags_base) -std=c++0x -Werror
-+ cppflags = $(cflags_base) -std=c++0x
- endif
--cflags = $(cflags_base) -Werror
-+cflags = $(cflags_base)
- inc_build = Build/Include
- includes = -IBuild/Include/ $(version_specific_includes)
- bundle_build = Build/Bundles
-@@ -407,7 +407,7 @@
- jar = $(JAVA_HOME)/bin/jar
- endif
-
--java_cflags = -fexceptions -Wall $(platform_java_cflags) $(version_specific_java_cflags) -Werror -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
-+java_cflags = -fexceptions -Wall $(platform_java_cflags) $(version_specific_java_cflags) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
- jarflags = cf
- dirsep = /
- prefix = /usr/local
-diff -ur ohNetGenerated/Makefile ohNetGenerated/Makefile
---- a/openhome/ohNetGenerated/Makefile 2020-11-09 23:46:21.344605971 -0600
-+++ b/openhome/ohNetGenerated/Makefile 2020-11-09 23:47:44.656814158 -0600
-@@ -276,13 +276,13 @@
- cflags_base = -fexceptions -Wall $(version_specific_cflags_third_party) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) -fvisibility=hidden $(platform_cflags)
- cflags_third_party = $(cflags_base) -Wno-int-to-pointer-cast
- ifeq ($(nocpp11), yes)
-- cppflags = $(cflags_base) -Werror
-+ cppflags = $(cflags_base)
- else ifeq ($(platform),IntelMac)
-- cppflags = $(cflags_base) -std=c++11 -Werror
-+ cppflags = $(cflags_base) -std=c++11
- else
-- cppflags = $(cflags_base) -std=c++0x -D__STDC_VERSION__=199901L -Werror
-+ cppflags = $(cflags_base) -std=c++0x -D__STDC_VERSION__=199901L
- endif
--cflags = $(cflags_base) -Werror
-+cflags = $(cflags_base)
- depsPlatform = ${openhome_system}-${openhome_architecture}
- header_install = Build/Include
- inc_build = dependencies/$(depsPlatform)/ohNet-$(depsPlatform)-Release/include/ohnet
-@@ -337,7 +337,7 @@
- jar = $(JAVA_HOME)/bin/jar
- endif
-
--java_cflags = -fexceptions -Wall $(version_specific_java_cflags) -Werror -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
-+java_cflags = -fexceptions -Wall $(version_specific_java_cflags) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
- jarflags = cf
- dirsep = /
- prefix = /usr/local
-diff -ur ohSongcast/Makefile ohSongcast/Makefile
---- a/openhome/ohSongcast/Makefile 2020-11-09 23:46:21.256605754 -0600
-+++ b/openhome/ohSongcast/Makefile 2020-11-09 23:47:23.130759816 -0600
-@@ -38,7 +38,7 @@
- # Macros used by Common.mak
-
- ar = ${CROSS_COMPILE}ar rc $(objdir)
--cflags = -fexceptions -Wall -Werror -pipe -std=c++11 -D_GNU_SOURCE -D_REENTRANT -DDEFINE_LITTLE_ENDIAN -DDEFINE_TRACE $(debug_specific_flags) -fvisibility=hidden -DDllImport="__attribute__ ((visibility(\"default\")))" -DDllExport="__attribute__ ((visibility(\"default\")))" -DDllExportClass="__attribute__ ((visibility(\"default\")))" $(platform_cflags)
-+cflags = -fexceptions -Wall -pipe -std=c++11 -D_GNU_SOURCE -D_REENTRANT -DDEFINE_LITTLE_ENDIAN -DDEFINE_TRACE $(debug_specific_flags) -fvisibility=hidden -DDllImport="__attribute__ ((visibility(\"default\")))" -DDllExport="__attribute__ ((visibility(\"default\")))" -DDllExportClass="__attribute__ ((visibility(\"default\")))" $(platform_cflags)
- ohnetdir = ../ohNet/Build/Obj/$(osdir)/$(build_dir)/
- ohnetgenerateddir = ../ohNetGenerated/Build/Obj/$(osdir)/$(build_dir)/
- ohtopologydir = ../ohTopology/build/