summaryrefslogtreecommitdiff
path: root/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch')
-rw-r--r--media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch b/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch
new file mode 100644
index 000000000000..fd079e26fb8a
--- /dev/null
+++ b/media-sound/sc2mpd/files/sc2mpd-1.1.7-werror.patch
@@ -0,0 +1,72 @@
+diff -ur ohNet/Makefile ohNet/Makefile
+--- a/openhome/ohNet/Makefile 2020-11-09 23:46:21.295605850 -0600
++++ b/openhome/ohNet/Makefile 2020-11-09 23:48:05.977868337 -0600
+@@ -344,13 +344,13 @@
+ cflags_base = -fexceptions -Wall $(version_specific_cflags_third_party) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) -fvisibility=hidden $(platform_cflags)
+ cflags_third_party = $(cflags_base) -Wno-int-to-pointer-cast
+ ifeq ($(nocpp11), yes)
+- cppflags = $(cflags_base) -Werror
++ cppflags = $(cflags_base)
+ else ifeq ($(platform),IntelMac)
+- cppflags = $(cflags_base) -std=c++11 -Werror
++ cppflags = $(cflags_base) -std=c++11
+ else
+- cppflags = $(cflags_base) -std=c++0x -Werror
++ cppflags = $(cflags_base) -std=c++0x
+ endif
+-cflags = $(cflags_base) -Werror
++cflags = $(cflags_base)
+ inc_build = Build/Include
+ includes = -IBuild/Include/ $(version_specific_includes)
+ bundle_build = Build/Bundles
+@@ -407,7 +407,7 @@
+ jar = $(JAVA_HOME)/bin/jar
+ endif
+
+-java_cflags = -fexceptions -Wall $(platform_java_cflags) $(version_specific_java_cflags) -Werror -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
++java_cflags = -fexceptions -Wall $(platform_java_cflags) $(version_specific_java_cflags) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
+ jarflags = cf
+ dirsep = /
+ prefix = /usr/local
+diff -ur ohNetGenerated/Makefile ohNetGenerated/Makefile
+--- a/openhome/ohNetGenerated/Makefile 2020-11-09 23:46:21.344605971 -0600
++++ b/openhome/ohNetGenerated/Makefile 2020-11-09 23:47:44.656814158 -0600
+@@ -276,13 +276,13 @@
+ cflags_base = -fexceptions -Wall $(version_specific_cflags_third_party) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) -fvisibility=hidden $(platform_cflags)
+ cflags_third_party = $(cflags_base) -Wno-int-to-pointer-cast
+ ifeq ($(nocpp11), yes)
+- cppflags = $(cflags_base) -Werror
++ cppflags = $(cflags_base)
+ else ifeq ($(platform),IntelMac)
+- cppflags = $(cflags_base) -std=c++11 -Werror
++ cppflags = $(cflags_base) -std=c++11
+ else
+- cppflags = $(cflags_base) -std=c++0x -D__STDC_VERSION__=199901L -Werror
++ cppflags = $(cflags_base) -std=c++0x -D__STDC_VERSION__=199901L
+ endif
+-cflags = $(cflags_base) -Werror
++cflags = $(cflags_base)
+ depsPlatform = ${openhome_system}-${openhome_architecture}
+ header_install = Build/Include
+ inc_build = dependencies/$(depsPlatform)/ohNet-$(depsPlatform)-Release/include/ohnet
+@@ -337,7 +337,7 @@
+ jar = $(JAVA_HOME)/bin/jar
+ endif
+
+-java_cflags = -fexceptions -Wall $(version_specific_java_cflags) -Werror -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
++java_cflags = -fexceptions -Wall $(version_specific_java_cflags) -pipe -D_GNU_SOURCE -D_REENTRANT -DDEFINE_$(endian)_ENDIAN -DDEFINE_TRACE $(debug_specific_cflags) $(platform_cflags)
+ jarflags = cf
+ dirsep = /
+ prefix = /usr/local
+diff -ur ohSongcast/Makefile ohSongcast/Makefile
+--- a/openhome/ohSongcast/Makefile 2020-11-09 23:46:21.256605754 -0600
++++ b/openhome/ohSongcast/Makefile 2020-11-09 23:47:23.130759816 -0600
+@@ -38,7 +38,7 @@
+ # Macros used by Common.mak
+
+ ar = ${CROSS_COMPILE}ar rc $(objdir)
+-cflags = -fexceptions -Wall -Werror -pipe -std=c++11 -D_GNU_SOURCE -D_REENTRANT -DDEFINE_LITTLE_ENDIAN -DDEFINE_TRACE $(debug_specific_flags) -fvisibility=hidden -DDllImport="__attribute__ ((visibility(\"default\")))" -DDllExport="__attribute__ ((visibility(\"default\")))" -DDllExportClass="__attribute__ ((visibility(\"default\")))" $(platform_cflags)
++cflags = -fexceptions -Wall -pipe -std=c++11 -D_GNU_SOURCE -D_REENTRANT -DDEFINE_LITTLE_ENDIAN -DDEFINE_TRACE $(debug_specific_flags) -fvisibility=hidden -DDllImport="__attribute__ ((visibility(\"default\")))" -DDllExport="__attribute__ ((visibility(\"default\")))" -DDllExportClass="__attribute__ ((visibility(\"default\")))" $(platform_cflags)
+ ohnetdir = ../ohNet/Build/Obj/$(osdir)/$(build_dir)/
+ ohnetgenerateddir = ../ohNetGenerated/Build/Obj/$(osdir)/$(build_dir)/
+ ohtopologydir = ../ohTopology/build/