summaryrefslogtreecommitdiff
path: root/media-sound/pasystray/pasystray-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pasystray/pasystray-0.8.0.ebuild')
-rw-r--r--media-sound/pasystray/pasystray-0.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/pasystray/pasystray-0.8.0.ebuild b/media-sound/pasystray/pasystray-0.8.0.ebuild
new file mode 100644
index 000000000000..3bbcec540569
--- /dev/null
+++ b/media-sound/pasystray/pasystray-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="PulseAudio system tray"
+HOMEPAGE="https://github.com/christophgysin/pasystray"
+SRC_URI="https://github.com/christophgysin/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libnotify zeroconf"
+
+RDEPEND="
+ dev-libs/glib
+ media-sound/pulseaudio[glib,zeroconf?]
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ zeroconf? ( net-dns/avahi )
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notify) \
+ $(use_enable zeroconf avahi)
+}