summaryrefslogtreecommitdiff
path: root/media-sound/mpdscribble/mpdscribble-0.25.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpdscribble/mpdscribble-0.25.ebuild')
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.25.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/mpdscribble/mpdscribble-0.25.ebuild b/media-sound/mpdscribble/mpdscribble-0.25.ebuild
new file mode 100644
index 000000000000..e21eff2664cf
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.25.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="
+ https://www.musicpd.org/clients/mpdscribble/
+ https://github.com/MusicPlayerDaemon/mpdscribble
+"
+SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+# Test program is just an interactive check.
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/libgcrypt:=
+ media-libs/libmpdclient
+ net-misc/curl
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS COPYING NEWS README.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.23-Unconditionally-generate-systemd-unit-files.patch
+ "${FILESDIR}"/${PN}-0.23-Don-t-install-AUTHORS-COPYING-NEWS-README.rst.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ keepdir /var/cache/mpdscribble
+
+ systemd_dounit "${BUILD_DIR}"/systemd/system/"${PN}".service
+ systemd_douserunit "${BUILD_DIR}"/systemd/user/"${PN}".service
+}