summaryrefslogtreecommitdiff
path: root/media-sound/mpd/mpd-0.22.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpd/mpd-0.22.5.ebuild')
-rw-r--r--media-sound/mpd/mpd-0.22.5.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-sound/mpd/mpd-0.22.5.ebuild b/media-sound/mpd/mpd-0.22.5.ebuild
index 2b67f0ccd3dd..9f489726eb47 100644
--- a/media-sound/mpd/mpd-0.22.5.ebuild
+++ b/media-sound/mpd/mpd-0.22.5.ebuild
@@ -16,11 +16,11 @@ IUSE="+alsa ao +audiofile bzip2 cdio chromaprint +cue +curl doc +dbus
+eventfd expat faad +ffmpeg +fifo flac fluidsynth gme +icu +id3tag +inotify
+ipv6 jack lame libmpdclient libsamplerate libsoxr +mad mikmod mms
modplug mpg123 musepack +network nfs openal opus oss pipe pulseaudio qobuz
- recorder samba selinux sid signalfd sndfile soundcloud sqlite systemd
+ recorder samba selinux sid signalfd sndfile sndio soundcloud sqlite systemd
test tidal twolame udisks vorbis wavpack webdav wildmidi upnp
zeroconf zip zlib"
-OUTPUT_PLUGINS="alsa ao fifo jack network openal oss pipe pulseaudio recorder"
+OUTPUT_PLUGINS="alsa ao fifo jack network openal oss pipe pulseaudio sndio recorder"
DECODER_PLUGINS="audiofile faad ffmpeg flac fluidsynth mad mikmod
modplug mpg123 musepack flac sid vorbis wavpack wildmidi"
ENCODER_PLUGINS="audiofile flac lame twolame vorbis"
@@ -88,6 +88,7 @@ RDEPEND="
media-libs/libsidplayfp
) )
sndfile? ( media-libs/libsndfile )
+ sndio? ( media-sound/sndio )
soundcloud? ( >=dev-libs/yajl-2:= )
sqlite? ( dev-db/sqlite:3 )
systemd? ( sys-apps/systemd )
@@ -193,6 +194,7 @@ src_configure() {
-Dpipe=$(usex pipe true false)
-Dpulse=$(usex pulseaudio enabled disabled)
-Drecorder=$(usex recorder true false)
+ -Dsndio=$(usex sndio enabled disabled)
)
if use samba || use upnp; then
@@ -247,7 +249,6 @@ src_configure() {
emesonargs+=(
--libdir="/usr/$(get_libdir)"
-Ddocumentation=$(usex doc enabled disabled)
- -Dsndio=disabled #not yet in the tree
-Dsolaris_output=disabled
-Ddatabase=true