summaryrefslogtreecommitdiff
path: root/media-sound/mp3check/mp3check-0.8.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mp3check/mp3check-0.8.4.ebuild')
-rw-r--r--media-sound/mp3check/mp3check-0.8.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/mp3check/mp3check-0.8.4.ebuild b/media-sound/mp3check/mp3check-0.8.4.ebuild
new file mode 100644
index 000000000000..98d0ca55455c
--- /dev/null
+++ b/media-sound/mp3check/mp3check-0.8.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings"
+HOMEPAGE="http://jo.ath.cx/soft/mp3check/index.html"
+SRC_URI="http://jo.ath.cx/soft/mp3check/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "/^WARN/s/-g//" Makefile || die
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" OPT="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin mp3check
+}