summaryrefslogtreecommitdiff
path: root/media-sound/jalv
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/jalv')
-rw-r--r--media-sound/jalv/Manifest5
-rw-r--r--media-sound/jalv/files/jalv-1.6.8-qt5-fPIC.patch15
-rw-r--r--media-sound/jalv/jalv-1.6.6.ebuild2
-rw-r--r--media-sound/jalv/jalv-1.6.8.ebuild59
4 files changed, 79 insertions, 2 deletions
diff --git a/media-sound/jalv/Manifest b/media-sound/jalv/Manifest
index 516b0d533ac9..1382f4c75118 100644
--- a/media-sound/jalv/Manifest
+++ b/media-sound/jalv/Manifest
@@ -1,4 +1,7 @@
AUX jalv-1.6.6-suil-always.patch 410 BLAKE2B 7aee87986df386383990e2fc1c012592c95793a3ed7d80faa98c1946130d591eca283db62954bd6c8419cb0b57ef600ece58886dc5c33be7eb0d0addc8b09d81 SHA512 534cc589ddf8f40f32c9c5febc71a6707bc546a6277f5fa556f65f2fff20f053851063449723708460279d22efb45b505f8bbc5e5316781164ed33993847bfb8
+AUX jalv-1.6.8-qt5-fPIC.patch 692 BLAKE2B e5af701a2a394897e5caa14efcdc39b0964b9549dab15da4da74fa370caee300aece7b0b7879d2e9b986ba8cac75d9de3c7786ebc8888bf9cecc7ba5b8dc13d5 SHA512 78101ea4193a05887b89fa4aae4b3ecb3e68308ca3e0ab90c81411ad3aeb79f7a6134ffdb45f38de20e7e74b4590608dc7f75d7609432183fb34213dcb33ae2b
DIST jalv-1.6.6.tar.bz2 356622 BLAKE2B 92e93a48cb0a244cdd3fa9264fe6faaaf9580fe035bb4af1358ecdfc6558766e75ff905592dc6ad43202b3b052331346c8b5e864bf88d2efdcfc6edb427fc715 SHA512 8bb77848a890326c8b39d4d6aea65a86c3cf44d7cb3474f20b0279d5f3a1935b955beb2905d315b304926c856029d5180d1e72f89b736e60def9eeab6e2b0f7c
-EBUILD jalv-1.6.6.ebuild 1225 BLAKE2B 41279164b25dc1780af6293e57dfd64623faf3bcfac22a408520a4bf01c40c10a0be1ffe8e885ff1d04aa12aadc8114939dc39f6f67784e48342c4ae4601e8a8 SHA512 e7a983d04024155d965aed445c469dd84232ddca921be0809928205e68ee5496d9fe0ca8150ea206cd25fca0ecc7e9f577ccf7fdea217e1cbfed425f46f66e40
+DIST jalv-1.6.8.tar.xz 60712 BLAKE2B d2264163821273bf40795d4dbfc1905c6ab334449461e311a18a6f667abafb92ed12afa8e9315bcf8d3f7bd3bde3a765994add294e5037b06349157f8b0bd734 SHA512 a3361239cbff8b02a0d46bb06480d727ad45abe1856ad4cec1a1299851392be04fdfa58ba6803ed2a446eb8964c4a44191733b53fe8529c65155b0221323428f
+EBUILD jalv-1.6.6.ebuild 1226 BLAKE2B 381778e571010aa658a95f091ee89c96ea8da3f536a150cb123dce2a793b679caf442b119a3892321dfe6464aa50a1d0de771c1c09a731332407cbc9732ae62b SHA512 c1330c1bdf662210072a07bbebba0ea70d24a8fa8c52fcc4a6f6db1bacbfc37b4b02c0a3730a18c5eeb551c7095e21468a95f19ce1eeeaaf65fc534f5b251b1a
+EBUILD jalv-1.6.8.ebuild 1068 BLAKE2B 5f3d7f36472fcdbaae9a3dba9bd954f1e080414e0c0f268da31069c40cf419b6a53dbd60bdf0ef92f8b03855d732ce1d5347dccec9b148debffe226f88200f6d SHA512 0975923e532ac79dee439d589deaec84424c52217a9dbe150ee4519779be7828add33fba218855556ce16a7737aea86d592b88ba81ceb4da6d87b9e17bdf0d9a
MISC metadata.xml 1052 BLAKE2B 31fa13d83562029a188556d91133d432f899d515f28f9f3254d17412b74ba2f123ba3cbdce0602a2cc8d16f887d74622928d462729fcdb7082380e78bf39cb37 SHA512 353e23ebb530a497d1fb70f3906326d02f10a0c5127c99133397ce575977f4e029fdad7933d3414edfdb585357061f4be6d218c1c9a1cac3ced2bf69f1fb35b3
diff --git a/media-sound/jalv/files/jalv-1.6.8-qt5-fPIC.patch b/media-sound/jalv/files/jalv-1.6.8-qt5-fPIC.patch
new file mode 100644
index 000000000000..3b0e3008662e
--- /dev/null
+++ b/media-sound/jalv/files/jalv-1.6.8-qt5-fPIC.patch
@@ -0,0 +1,15 @@
+diff --git a/meson.build b/meson.build
+index 9ebc14f..25e3704 100644
+--- a/meson.build
++++ b/meson.build
+@@ -344,8 +344,8 @@ if not get_option('qt5').disabled()
+ executable(
+ 'jalv.qt5',
+ sources + files('src/jalv_qt.cpp') + [jalv_qt5_meta_cpp],
+- c_args: c_suppressions + platform_defines + suil_defines,
+- cpp_args: cpp_suppressions + platform_defines + suil_defines,
++ c_args: c_suppressions + platform_defines + suil_defines + '-fPIC',
++ cpp_args: cpp_suppressions + platform_defines + suil_defines + '-fPIC',
+ dependencies: common_dependencies + [qt5_dep, suil_dep],
+ include_directories: include_directories('src'),
+ install: true,
diff --git a/media-sound/jalv/jalv-1.6.6.ebuild b/media-sound/jalv/jalv-1.6.6.ebuild
index 4e6f6c0e6aa8..2a12a7a0924d 100644
--- a/media-sound/jalv/jalv-1.6.6.ebuild
+++ b/media-sound/jalv/jalv-1.6.6.ebuild
@@ -9,7 +9,7 @@ inherit python-any-r1 qmake-utils waf-utils
DESCRIPTION="Simple but fully featured LV2 host for Jack"
HOMEPAGE="https://drobilla.net/software/jalv.html"
-SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+SRC_URI="https://download.drobilla.net/${P}.tar.bz2"
LICENSE="ISC"
SLOT="0"
diff --git a/media-sound/jalv/jalv-1.6.8.ebuild b/media-sound/jalv/jalv-1.6.8.ebuild
new file mode 100644
index 000000000000..010f8cf631b9
--- /dev/null
+++ b/media-sound/jalv/jalv-1.6.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson qmake-utils flag-o-matic xdg
+
+DESCRIPTION="Simple but fully featured LV2 host for Jack"
+HOMEPAGE="https://drobilla.net/software/jalv.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gtk jack portaudio qt5"
+
+RDEPEND="
+ dev-libs/serd
+ dev-libs/sord
+ media-libs/lilv
+ media-libs/lv2
+ media-libs/sratom
+ media-libs/suil
+ gtk? ( x11-libs/gtk+:3 )
+ jack? ( virtual/jack )
+ portaudio? ( media-libs/portaudio )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+DOCS=( AUTHORS NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt5-fPIC.patch"
+)
+
+src_configure() {
+ use qt5 && export PATH="$(qt5_get_bindir):${PATH}"
+
+ local emesonargs=(
+ $(meson_feature gtk gtk3)
+ $(meson_feature jack)
+ $(meson_feature portaudio)
+ $(meson_feature qt5)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ append-flags -fPIC
+
+ meson_src_compile
+}