summaryrefslogtreecommitdiff
path: root/media-sound/gpodder
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gpodder')
-rw-r--r--media-sound/gpodder/Manifest2
-rw-r--r--media-sound/gpodder/gpodder-3.11.0.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/media-sound/gpodder/Manifest b/media-sound/gpodder/Manifest
index e7df8d93c94b..914c9d79c3ac 100644
--- a/media-sound/gpodder/Manifest
+++ b/media-sound/gpodder/Manifest
@@ -1,3 +1,5 @@
DIST gpodder-3.10.21.tar.gz 1105520 BLAKE2B c17905951c14a718e48d1bbded3abc41d62088bb517cda053e9fa71e3a952bb97ac57077d428cd58c3a048ae0cc18ef9385af97dcf8b460f3860674ecdb85c1c SHA512 5311a92469f605e489553e91586b788a8d07812e41c20d1ad0717c09ab6db6da22c356d5c1942293d1e27e25afe24caf3c14c15720250d8f230f2d7738206fec
+DIST gpodder-3.11.0.tar.gz 1155120 BLAKE2B b2e46a5ea5ceec7df632f888b00e9c25a0ec1c4597540228b50cb75bd4bd6acfc7566cfffe5c9d133e8ec29e1ffc2f4551e2fd289237d1b93d2e80f6b49db0c1 SHA512 90e33e04a8afcdafa0899f25714417ce61699c641ce3df93b3a3728224bdb0be5205c064e7263d1be1f4641e61932b945741e9848726b602633a94eb754fa937
EBUILD gpodder-3.10.21-r1.ebuild 2133 BLAKE2B 3e434d2681a559a1a13f471b0c889b83d4343f607e7164377e6df96418f45bdc50408ecb73d5569d5d8035eb056970273912c7e0729d23cde0403ff1c7b9733f SHA512 2530fd53802d9f32e51c92750f0b58ac9b3eaad5ef8e9ee39418941421b663be4da5586078451c249abe78c486dd139fb31081f4c59d15726acd20541f59eae9
+EBUILD gpodder-3.11.0.ebuild 2172 BLAKE2B 490750c4c525b411d18016719c77b8cd8471d25801d95f4a1abcad870656bd374e3b6857fb416191ec34b1fa060b65caa34b14ef3db8817a274b81532b8073d5 SHA512 13a0b8c4cf34631756940b589a7281c741df293e769cbe223783acce0dc420ead7c864566f4e3e9840ec7e222842e71a32442928c9933a5a47ba1f94d98241ed
MISC metadata.xml 358 BLAKE2B 272a71d2d7d519dca74a2d1dbbd25d0c48b55b265eca16962967f57dc29edfeca9d454100a84a7dd505f5bab7778778ff45b89f2ddaca152b562733e8c0dcce8 SHA512 31b12848c3f24a103f2bfa39bec4b2c4e3251ed70de194d569acfbe2b7df3f8ea28dd5ba274b4add0fbc1b55d998cf13f5b8f7bf89bb4a95fd1e60e988bce6f6
diff --git a/media-sound/gpodder/gpodder-3.11.0.ebuild b/media-sound/gpodder/gpodder-3.11.0.ebuild
new file mode 100644
index 000000000000..f2ab5d507ec5
--- /dev/null
+++ b/media-sound/gpodder/gpodder-3.11.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="A free cross-platform podcast aggregator"
+HOMEPAGE="https://gpodder.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus bluetooth mtp"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
+ >=dev-python/podcastparser-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/mygpoclient-1.8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ ')
+ bluetooth? ( net-wireless/bluez )
+ mtp? ( >=media-libs/libmtp-1.0.0:= )
+ kernel_linux? ( sys-apps/iproute2 )
+"
+BDEPEND="
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-apps/help2man
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/minimock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--cov=gpodder::' makefile || die
+}
+
+python_test() {
+ # These are pulled out from the Makefile to give us more control
+ # See bug #795165
+ # Previously, we used 'emake releasetest' in src_test
+ LC_ALL=C epytest --ignore=tests --ignore=src/gpodder/utilwin32ctypes.py --doctest-modules src/gpodder/util.py src/gpodder/jsonconfig.py \
+ -p no:localserver
+ LC_ALL=C epytest tests --ignore=src/gpodder/utilwin32ctypes.py --ignore=src/mygpoclient \
+ -p no:localserver
+}
+
+src_install() {
+ emake PYTHON="${EPYTHON}" DESTDIR="${D}" install
+
+ distutils-r1_src_install
+
+ touch "${ED}"/usr/share/gpodder/no-update-check || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "track length detection for device sync (only one package is needed)" media-video/mplayer dev-python/eyeD3
+ optfeature "for the YouTube extension" net-misc/yt-dlp net-misc/youtube-dl
+ optfeature "iPod sync support" media-libs/libgpod
+}