summaryrefslogtreecommitdiff
path: root/media-sound/gom/gom-0.29.103-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gom/gom-0.29.103-r1.ebuild')
-rw-r--r--media-sound/gom/gom-0.29.103-r1.ebuild34
1 files changed, 13 insertions, 21 deletions
diff --git a/media-sound/gom/gom-0.29.103-r1.ebuild b/media-sound/gom/gom-0.29.103-r1.ebuild
index b49d71e781ed..241883a1f654 100644
--- a/media-sound/gom/gom-0.29.103-r1.ebuild
+++ b/media-sound/gom/gom-0.29.103-r1.ebuild
@@ -1,45 +1,37 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools toolchain-funcs
+inherit autotools
DESCRIPTION="Console Mixer Program for OSS"
HOMEPAGE="http://www.fh-worms.de/~inf222"
SRC_URI="http://www.Fh-Worms.DE./~inf222/code/c/gom/released/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86"
-IUSE="examples"
-DEPEND=">=sys-libs/ncurses-5.2:0="
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}/${P}-tinfo.patch"
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
default
+ rmdir examples/standard || die
+ mv configure.{in,ac} || die
eautoreconf
}
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-}
-
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS ChangeLog README
-
- if use examples; then
- docinto examples
- dodoc README
- docinto examples/default
- dodoc examples/default/*
- docinto examples/two-mixers
- dodoc examples/two-mixers/*
- fi
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
}