summaryrefslogtreecommitdiff
path: root/media-sound/gom/gom-0.29.103-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gom/gom-0.29.103-r1.ebuild')
-rw-r--r--media-sound/gom/gom-0.29.103-r1.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/media-sound/gom/gom-0.29.103-r1.ebuild b/media-sound/gom/gom-0.29.103-r1.ebuild
index 30295a79e97a..b49d71e781ed 100644
--- a/media-sound/gom/gom-0.29.103-r1.ebuild
+++ b/media-sound/gom/gom-0.29.103-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Console Mixer Program for OSS"
HOMEPAGE="http://www.fh-worms.de/~inf222"
@@ -14,15 +14,24 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc sparc x86"
IUSE="examples"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2:0="
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-tinfo.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_compile() {
- econf
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed."
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed."
+src_install() {
+ emake DESTDIR="${D}" install
dodoc AUTHORS NEWS ChangeLog README
if use examples; then