summaryrefslogtreecommitdiff
path: root/media-sound/gnomad/gnomad-2.9.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gnomad/gnomad-2.9.6-r1.ebuild')
-rw-r--r--media-sound/gnomad/gnomad-2.9.6-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/gnomad/gnomad-2.9.6-r1.ebuild b/media-sound/gnomad/gnomad-2.9.6-r1.ebuild
new file mode 100644
index 000000000000..e9213c0f3878
--- /dev/null
+++ b/media-sound/gnomad/gnomad-2.9.6-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A GTK+ music manager for the Portable Digital Entertainment (PDE) protocol"
+HOMEPAGE="http://gnomad2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="nls"
+
+RDEPEND="
+ dev-libs/libgudev:=
+ media-libs/libid3tag:=
+ media-libs/libmtp:=
+ media-libs/libnjb
+ media-libs/taglib
+ >=x11-libs/gtk+-2.24:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.9.6-fno-common.patch )
+DOCS=( AUTHORS README TODO ) # ChangeLog and NEWS are both outdated
+
+src_configure() {
+ econf $(use_enable nls)
+}