summaryrefslogtreecommitdiff
path: root/media-sound/darkice/darkice-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/darkice/darkice-1.3.ebuild')
-rw-r--r--media-sound/darkice/darkice-1.3.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/media-sound/darkice/darkice-1.3.ebuild b/media-sound/darkice/darkice-1.3.ebuild
index 2a4e5be0de1a..b3c01b466369 100644
--- a/media-sound/darkice/darkice-1.3.ebuild
+++ b/media-sound/darkice/darkice-1.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit eutils
DESCRIPTION="A live audio streamer"
HOMEPAGE="http://www.darkice.org/"
@@ -9,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
IUSE="aac aacplus alsa debug jack libsamplerate mp3 opus pulseaudio twolame vorbis"
RDEPEND="aac? ( media-libs/faac )
@@ -27,21 +28,23 @@ DEPEND="${RDEPEND}"
REQUIRED_USE="|| ( aac aacplus mp3 opus twolame vorbis )
|| ( alsa jack pulseaudio )"
+#PATCHES=(
+# "${FILESDIR}"/${PN}-1.2-gcc47.patch
+#)
+
src_configure() {
- local myeconfargs=(
- $(use_enable debug)
- $(use_with aac faac)
- $(use_with aacplus)
- $(use_with alsa)
- $(use_with jack)
- $(use_with libsamplerate samplerate)
- $(use_with mp3 lame)
- $(use_with opus)
- $(use_with pulseaudio)
- $(use_with twolame)
+ econf \
+ $(use_enable debug) \
+ $(use_with aac faac) \
+ $(use_with aacplus) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with libsamplerate samplerate) \
+ $(use_with mp3 lame) \
+ $(use_with opus) \
+ $(use_with pulseaudio) \
+ $(use_with twolame) \
$(use_with vorbis)
- )
- econf "${myeconfargs[@]}"
}
src_install() {